cruise control not working, service engine light on - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Kizashi
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-02-2014, 04:55 PM   #1 (permalink)
Newbie
 
Join Date: Jun 2014
Posts: 1
Gallery: 0
susannal is on a distinguished road
Thumbs up cruise control not working, service engine light on

When I started my Kizashi the other day the panel read "service engine" and the cruise control no longer worked.

Any ideas for a quick fix before taking it to the garage?
susannal is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-02-2014, 05:49 PM   #2 (permalink)
Moderator
 
Join Date: Mar 2009
Location: Georgetown, Guyana
Posts: 11,941
Gallery: 0
fordem will become famous soon enough
Default

Get the codes read - it's not unusual for the cruise to be disabled when the check light is on.
__________________
98 - 1.8 Mitsubishi Pajero iO
98 - 2.0 Suzuki Grand Vitara - SQ420
05 - 2.0 Suzuki Grand Vitara - JB420
15 - 2.4 Kia Sportage
fordem is offline   Reply With Quote Quick reply to this message
Old 06-09-2014, 08:02 PM   #3 (permalink)
Member
 
Join Date: Dec 2013
Posts: 31
Gallery: 0
SamirD is on a distinguished road
Default

If the check engine doesn't go off on its own, then I think you'll have to find out what's wrong. These cars usually don't have any real issues like this.

Otherwise, once the light goes out, the cruise control should work fine again.
SamirD is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Kizashi

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:06 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.