Took my sammy to mechanic.... - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-13-2013, 01:50 PM   #1 (permalink)
Newbie
 
Join Date: Oct 2013
Posts: 7
Gallery: 0
sickmaniak is on a distinguished road
Default Took my sammy to mechanic....

They changed out the heater core ..fuel pump..and did a valve adjustment(600 miles on a rebuild)Now the engine is shaking and runs like crap..They say that cylinder 3 is getting spark but not firing.Also they can't seem to get the valve cover to stop leaking like crazy..I am pissed,The one guy's excuse is he hates cork gaskets.Keep in mind when i took it in it ran like a gem except it leaked gas so we swapped out the fuel filter?Now what do I do?

Last edited by XL7Limited; 12-16-2013 at 05:55 AM.
sickmaniak is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-13-2013, 05:21 PM   #2 (permalink)
Expert
 
caseyjones955's Avatar
 
Join Date: Oct 2011
Location: Black Hills of South Dakota
Posts: 683
Gallery: 0
caseyjones955 is on a distinguished road
Default

I would verify that the valve adjustment was done correctly, botching this will make it run crappy. I hate cork gaskets to but they do seal if installed correctly. Mechanics like this that made me learn how to service things myself, sorry you had this experience.

Does this shop have a HQ like a franchise or is it an independent small shop? I wonder if talking to the shops owner would get you anywhere.
__________________
87 Samurai ragtop, 16v 1.6L MPFI, Thorley header, 2.25" exh w/magnaflow cat & muffler, full custom dash & instruments, PS, AC, 410 Toyota axles w/rear lockrite and front ARB, Jeep YJ springs, Missing links, 6.4:1 xfer gears with twisted T conversion, early 5 speed, 35x12.5 Wranglers. .
caseyjones955 is offline   Reply With Quote Quick reply to this message
Old 12-13-2013, 11:01 PM   #3 (permalink)
Senior
 
Azelgin's Avatar
 
Join Date: Oct 2010
Location: S. E. Arizona
Posts: 264
Gallery: 0
Azelgin is on a distinguished road
Default

Quote:
Originally Posted by sickmaniak View Post
They changed out the heater core ..fuel pump..and did a valve adjustment(600 miles on a rebuild)Now the engine is shaking and runs like shit..They say that cylynder 3 is getting spark but not firing.Also they can't seem to get the valve cover to stop leaking like crazy..I am pissed,The one guy's excuse is he hates cork gaskets.Keep in mind when i took it in it ran like a gem except it leaked gas so we swapped out the fuel filter?Now what do I do?
Is this the same "mechanic" that hollowed out your thermostat? Either he adjusted your valves too tight, or, the adjustment backed off and the valve is no longer opening. Leaking valve cover gasket? No excuse for that. An easy item to install correctly by ANY competent mechanic. You need to learn to do these things yourself, or, find someone else. Sounds like you could do a better job than the guy doing your work for you. Is he a relative?
Azelgin is offline   Reply With Quote Quick reply to this message
 
Old 12-15-2013, 12:13 PM   #4 (permalink)
Newbie
 
Join Date: Oct 2013
Posts: 7
Gallery: 0
sickmaniak is on a distinguished road
Default

Yes it is a franchise...Now they say it is running well and that it was "flooded"And the heat still doesn't work as the mechanic said he doesn't know if the replacement heater core(used of course) had a restriction or not!Why wouldn't he check it first?What a nightmare.
sickmaniak is offline   Reply With Quote Quick reply to this message
Old 12-15-2013, 05:51 PM   #5 (permalink)
Expert
 
caseyjones955's Avatar
 
Join Date: Oct 2011
Location: Black Hills of South Dakota
Posts: 683
Gallery: 0
caseyjones955 is on a distinguished road
Default

Is it running well now? He sounds like a real DB.

Consider checking with home office of the shop and seek refund. It sounds like they effed up every part of it they touched.

You do know that there will be no heat in the dash vents, only at the floor and defrost, this is by design.

Just curious, what did they charge you for a used core?
__________________
87 Samurai ragtop, 16v 1.6L MPFI, Thorley header, 2.25" exh w/magnaflow cat & muffler, full custom dash & instruments, PS, AC, 410 Toyota axles w/rear lockrite and front ARB, Jeep YJ springs, Missing links, 6.4:1 xfer gears with twisted T conversion, early 5 speed, 35x12.5 Wranglers. .
caseyjones955 is offline   Reply With Quote Quick reply to this message
Old 12-16-2013, 05:45 AM   #6 (permalink)
Newbie
 
Join Date: Oct 2013
Posts: 7
Gallery: 0
sickmaniak is on a distinguished road
Default

I bought it on ebay for $65......ok so I'll check the heat like you said didn't realize that.
sickmaniak is offline   Reply With Quote Quick reply to this message
Old 12-16-2013, 09:10 AM   #7 (permalink)
Expert
 
caseyjones955's Avatar
 
Join Date: Oct 2011
Location: Black Hills of South Dakota
Posts: 683
Gallery: 0
caseyjones955 is on a distinguished road
Default

Cool (no pun intended)

I was trying to think of ways to plum it so the heat would work in the vents as I LOVE my vent heat but I just had this beast out in -4 deg weather last week and the floor heat was ample for the entire vehicle, just didn't need the vents. It didn't roast me out of the cabin or anything but after 10 minutes of driving I was turning the blower down a notch.

Since your heater core was just replaced it shouldn't have the layer of dry leaves covering it up. If the blower motor is healthy you should be getting some decent heat below if your engine is reaching operating temp.
__________________
87 Samurai ragtop, 16v 1.6L MPFI, Thorley header, 2.25" exh w/magnaflow cat & muffler, full custom dash & instruments, PS, AC, 410 Toyota axles w/rear lockrite and front ARB, Jeep YJ springs, Missing links, 6.4:1 xfer gears with twisted T conversion, early 5 speed, 35x12.5 Wranglers. .
caseyjones955 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:20 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.