samurai starts but won't run - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-08-2013, 05:43 PM   #1 (permalink)
Newbie
 
Join Date: Apr 2010
Posts: 20
Gallery: 0
zukin is on a distinguished road
Default samurai starts but won't run

just got a 92 samurai, it will start if I put fuel down the tbi.
will only run until fuel runs out.
installed new fuel pump & filter, tried different ecm from a buddy.
anyone have any ideas or suggestions?
zukin is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 12-08-2013, 07:28 PM   #2 (permalink)
Member
 
Join Date: Oct 2007
Posts: 29
Gallery: 0
gregman is on a distinguished road
Default

Here's a thought or two:
1) Check fuel pump relay if you have one
2) Was the ecm from the same type of transmission? Manual ECM different from Automatic ECM...
__________________
Love my putt putt !!!!

1991 8V 1.6L 2Dr 4X4 Sidekick.....original Canadian owner !!!!! 340,000+ km and going!! 22 yrs old...
gregman is offline   Reply With Quote Quick reply to this message
Old 12-08-2013, 07:35 PM   #3 (permalink)
Newbie
 
Join Date: Apr 2010
Posts: 20
Gallery: 0
zukin is on a distinguished road
Default

maybe I should have mention this is a samurai.
new fuel pump works fine have gas right up to the tbi.
ecm came from 91 samurai so it is the same as my 92
zukin is offline   Reply With Quote Quick reply to this message
 
Old 12-08-2013, 08:12 PM   #4 (permalink)
Member
 
Join Date: Oct 2007
Posts: 29
Gallery: 0
gregman is on a distinguished road
Default

oops....you're right...Samurai different from Sidekick...sorry....just trying to help.
__________________
Love my putt putt !!!!

1991 8V 1.6L 2Dr 4X4 Sidekick.....original Canadian owner !!!!! 340,000+ km and going!! 22 yrs old...
gregman is offline   Reply With Quote Quick reply to this message
Old 12-09-2013, 06:42 AM   #5 (permalink)
Guest
 
Join Date: Jun 2008
Location: The Kingdom of England
Posts: 5,299
Gallery: 5
Rhinoman is on a distinguished road
Default

Have you tried pulling codes while cranking? the ECU looks for a feedback signal from the ignition and if it doesn't see it it will cut fueling.
Rhinoman is offline   Reply With Quote Quick reply to this message
Old 12-10-2013, 06:24 AM   #6 (permalink)
Newbie
 
Join Date: Apr 2010
Posts: 20
Gallery: 0
zukin is on a distinguished road
Default

I have check engines with fuse in service slot in fuse panel with ignition on, it give engine code 12 which means everything is normal.
didn't know you could check codes when cranking?
zukin is offline   Reply With Quote Quick reply to this message
Old 12-10-2013, 06:45 AM   #7 (permalink)
Guest
 
Join Date: Jun 2008
Location: The Kingdom of England
Posts: 5,299
Gallery: 5
Rhinoman is on a distinguished road
Default

Cam sensor codes only show while cranking. Have you got a noid light? you should check the the injector is receiving a signal from the ECU.
Rhinoman is offline   Reply With Quote Quick reply to this message
Old 12-15-2013, 08:31 AM   #8 (permalink)
Newbie
 
Join Date: Apr 2010
Posts: 20
Gallery: 0
zukin is on a distinguished road
Default

what tells the ecm to pulse the injector?
zukin is offline   Reply With Quote Quick reply to this message
Old 12-15-2013, 09:47 AM   #9 (permalink)
Guest
 
Join Date: Jun 2008
Location: The Kingdom of England
Posts: 5,299
Gallery: 5
Rhinoman is on a distinguished road
Default

The camshaft sensor but you have spark so that should be OK. Did you check the codes while cranking? if that still shows OK then its probably a faulty ECU.
Rhinoman is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:35 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.