Sierra Problems - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-09-2013, 08:06 AM   #1 (permalink)
Newbie
 
Join Date: Oct 2013
Posts: 3
Gallery: 0
sierraboy is on a distinguished road
Default Sierra Problems

Hey Everyone! Im new here and bought a sierra for the first time!

A few problems have arose, if anyone can help me it would amazing!

I have a Suzuki Sierra 1.3L Carby in australia, 4 cyl. 1992/93. Softtop


1. Engine keeps shutting off as the revs slowly go down to 0 when stopped at traffic light of in neutral etc. (Except, when the lights are on, it doesnt do it- weirrdd)

2. It really smells like fuel as I drive

3. I'm pretty sure its using more fuel than its meant to

4. Theres a hole in one of the hoses and im pretty sure its coolant which spays out everytime the accelator is pressed.


So ye, thats pretty much it!

Thanks for your time.
sierraboy is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-09-2013, 08:55 AM   #2 (permalink)
Moderator
 
Join Date: Mar 2009
Location: Georgetown, Guyana
Posts: 12,012
Gallery: 0
fordem will become famous soon enough
Default

Quote:
Originally Posted by sierraboy View Post
I have a Suzuki Sierra 1.3L Carby in australia, 4 cyl. 1992/93. Softtop


1. Engine keeps shutting off as the revs slowly go down to 0 when stopped at traffic light of in neutral etc. (Except, when the lights are on, it doesnt do it- weirrdd)
Check your idle settings - there is a separate "idle up" mechanism that sets the idle speed higher when there is an electrical load (like the lights), so if this were set correctly whilst the main idle speed setting was wrong, it would explain why it doesn't stall when the lights are on.

Given this and the other fuel related problems, you might want to have that carburetor serviced.

As for the leaking hose - replace it.
__________________
98 - 1.8 Mitsubishi Pajero iO
98 - 2.0 Suzuki Grand Vitara - SQ420
05 - 2.0 Suzuki Grand Vitara - JB420
15 - 2.4 Kia Sportage
fordem is offline   Reply With Quote Quick reply to this message
Old 10-09-2013, 09:14 AM   #3 (permalink)
Newbie
 
Join Date: Oct 2013
Posts: 3
Gallery: 0
sierraboy is on a distinguished road
Default

ok cool thanks il check it out, not sure if this is a stupid question or not..but, how do you check/change your idle settings?
sierraboy is offline   Reply With Quote Quick reply to this message
 
Old 10-09-2013, 10:23 AM   #4 (permalink)
Moderator
 
Join Date: Mar 2009
Location: Georgetown, Guyana
Posts: 12,012
Gallery: 0
fordem will become famous soon enough
Default

It's not a stupid question, but, it indicates that you don't have the experience required.

There will be a number of screws - one to set the idle mixture and one or more to set the idle speed - my carb has four idle speed adjustments, fast idle (only active on a cold start), main idle (active when none of the remaining three are active), electrical load "idle up" (active when there is an electrical load - lights, defrost, blower fan) and a/c "idle up" (active when the a/c is on).

My suggestion is that you find a mechanic or a friend familiar with carbureted engines to guide you.
__________________
98 - 1.8 Mitsubishi Pajero iO
98 - 2.0 Suzuki Grand Vitara - SQ420
05 - 2.0 Suzuki Grand Vitara - JB420
15 - 2.4 Kia Sportage
fordem is offline   Reply With Quote Quick reply to this message
Old 10-09-2013, 07:55 PM   #5 (permalink)
Member
 
morbo's Avatar
 
Join Date: Oct 2013
Location: N.S.W, Australia
Posts: 36
Gallery: 0
morbo is on a distinguished road
Default

whats your location sierraboy? Im no mechanic,but i have a crapload of spares , and i played with the zooks idle and mixture alot before i swapped motor .
__________________
g16a powered 89 zook, because i can fix it
2005 x -cop BMW 1150 rt ,Because i don`t have too
morbo is offline   Reply With Quote Quick reply to this message
Old 10-10-2013, 05:24 AM   #6 (permalink)
Newbie
 
Join Date: Oct 2013
Posts: 3
Gallery: 0
sierraboy is on a distinguished road
Default

ok cool thanks man il get a mechanic to check it out
sierraboy is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:36 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.