G13bb tps problems? - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-30-2013, 04:34 AM   #1 (permalink)
Newbie
 
Join Date: Nov 2012
Posts: 3
Gallery: 0
jimnyg13bb is on a distinguished road
Default G13bb tps problems?

Hi i have a 2000 suzuki jimny with the g13bb motor

i have recently changed the auto transmission and every things seems to work fine

after changing the transmission when i hooked up the tps everything seems fine but after 2000RPM the rpms start to fluctuate until like 4000rpm then revs normal

this happens when free revving in nuetral and in drive the car drives but jerks violently until its florred and goes over 4000rpm


i disconnected the tps and every thing works fine just the transmission wont kickdown by its self

so i assumed it was a faulty tps so got a brand new one for $250 and it does the same thing????

few things i tried is i move the tps position (screws removed) a few degrees and it seems to work fine but then the screw holes wont line up? and i never removed it in the first place so can see how adjustment can go out.


i realy need to fox this to gain kickdown been driving like this for a few months know..



Thanks!
jimnyg13bb is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-02-2013, 06:52 AM   #2 (permalink)
Guest
 
Join Date: Jun 2008
Location: The Kingdom of England
Posts: 5,299
Gallery: 5
Rhinoman is on a distinguished road
Default

Kickdown won't work if you have any faults registered with the ECU or TCM, have you got any warning lights showing on the dash? If you have removed the TPS then you will need to reset it as per the FSM which can be found here:

http://www.rhinoman.org
Rhinoman is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:05 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.