Sami stalling while driving - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Closed Thread
 
LinkBack Thread Tools Display Modes
Old 07-31-2013, 01:27 PM   #1 (permalink)
Newbie
 
Join Date: Jul 2013
Location: Wyoming
Posts: 9
Gallery: 0
jime307 is on a distinguished road
Default Sami stalling while driving

It's the strangest thing. My 86 Samurai died while going down a hill, just turned off no stutter or anything. I pulled over at the bottom and checked my fluids and everything seemed fine. However now I can't get it started easily, I have to continually turn the motor and mash the accelerator and take off right away or the engine will die immediately. And it stutters while first accelerating but by the time I get to around 30mph it will smooth out and run just fine. However when I get to slowing down it will consistently die around 20mph. I am stumped I replaced the spark plugs and fuel filter and am still having the same issue what else could it be? I though maybe I could've blown a tooth on my timing belt or something but not sure it would make it act in this particular manner. The carburetor is an aftermarket weber 32/36 and it's new so I'm not sure if that could be problematic or not.

Any advice is greatly appreciated, sorry for the novel, but just trying to cover all the issues.

Thanks a ton!
Jim
jime307 is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-31-2013, 02:10 PM   #2 (permalink)
Max
Moderator
 
Max's Avatar
 
Join Date: Aug 2006
Location: South Carolina, USA
Posts: 17,335
Gallery: 0
Max will become famous soon enough
Default

Jim. Re-post in detail, in accordance with the link below and the folks here will try their best to assist you.

https://www.suzuki-forums.com/new-mem...tart-here.html
__________________
'99 Grand Vitara JLX, 2.5L V-6, 4WD, 5 spd std, '00 "Limited" leather interior
'72 Nova. SB, TH-350, PB, PS, A/C.
Max is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Closed Thread

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:21 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.