Losing fire intermittently on rough trails. - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-28-2013, 09:11 AM   #1 (permalink)
Newbie
 
Join Date: Mar 2013
Location: Arizona
Posts: 19
Gallery: 0
JungleJim0745 is on a distinguished road
Default Losing fire intermittently on rough trails.

I have an 87 Samurai that I nicknamed the REJECT because of the license plate number given to me by AZ for it, REJ1. I was looking for some answers when I came across this forum and thought maybe someone here would have the answer I need.

I recently changed to a Weber two bbl carb from the original and it runs super with it, well most of the time. After some time I am now having a problem out on the rough trails that I am unable to figure out and parts changing is very expensive on these little jewels. REJECT runs like a scalded dog on roads and idles as smooth as silk, BUT when we hit the trails it is seemingly loosing fire intermittently. Once we start bouncing along a rocky or rough trail it cuts out and it is clearly an electrical problem, because when I let off it idles perfectly, or if I stop it runs great idling or revved up.

I changed the plug wires, cap, rotor, and coil with no good results, it still does the same thing. I am thinking the ECM but those things are super expensive and I don't want to just change a bunch of parts in an effort to find and fix the problem. Anyone have any suggestions or knowledge that might help without spending 400 bucks for an ECM, has anyone had the same problem. Any help will be appreciated.

Someone said ECM no longer needed with Weber on it, but I can't find any info on how to get rid of the ECM.

I have a lot invested in my REJECT, things like air shocks all the way around, spring shackles vice flipping the axles, Weber carb, lots of cash in paint and clearcoat, interior mods, etc. so trying to avert any unnecessary additional costs if possible.

Last edited by JungleJim0745; 03-28-2013 at 09:14 AM.
JungleJim0745 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-28-2013, 10:06 AM   #2 (permalink)
Moderator
 
Join Date: Mar 2009
Location: Georgetown, Guyana
Posts: 11,948
Gallery: 0
fordem will become famous soon enough
Default

As far as I know the ECM on an 87 Sami was only used to control the mixture via a solenoid on the OEM Hitachi carburetor - since you have already removed that, you can simply unplug the ECU and everything else should be fine.

Which weber are you running? The 36/36 Weber is very popular on the Samis, but is known to be problematic - they are sensitive to angle (as in will flood easily when the vehicle is on an incline) and also to fuel pressure.

You seem to feel that this is an electrical issue because the vehicle runs well on road but not on a trail - the reason I have mentioned the flooding issue is that I have seen situations where vibration caused by a rough trail can provoke flooding.
__________________
98 - 1.8 Mitsubishi Pajero iO
98 - 2.0 Suzuki Grand Vitara - SQ420
05 - 2.0 Suzuki Grand Vitara - JB420
15 - 2.4 Kia Sportage

Last edited by fordem; 03-28-2013 at 11:59 AM. Reason: grammar
fordem is online now   Reply With Quote Quick reply to this message
Old 03-28-2013, 10:51 AM   #3 (permalink)
Senior
 
Join Date: Feb 2012
Location: Astoria Oregon
Posts: 278
Gallery: 3
Boxcar is on a distinguished road
Garage
Default

x2 It's called flutter. You're float bounces inside the bowl and causes over and under fueling.
Common with Webber's. The fix is : find a Webber guru and have him or her add a mountain kit. ( Webber voodoo ) or a Yota 1200 carb , or a my side , or efi , ETC.
As to you're ECM. Pull it and pass it on to someone running a stock carb.
Boxcar is offline   Reply With Quote Quick reply to this message
 
Old 03-28-2013, 07:27 PM   #4 (permalink)
Newbie
 
Join Date: Mar 2013
Location: Arizona
Posts: 19
Gallery: 0
JungleJim0745 is on a distinguished road
Default

Thanks to both of you, and you are both right on. I took the REJECT out on the trails today and with finesse I can make it work, but I would rather fix it. Where do I find the mountain kit for it. I have searched the internet to no avail. I have been a mechanic professionally for many years and owned garages, done many a modification that people said could not be done, so I don't think this will be a thing that beats me. LOL Thanks again.
JungleJim0745 is offline   Reply With Quote Quick reply to this message
Old 03-28-2013, 09:34 PM   #5 (permalink)
Moderator
 
Join Date: Mar 2009
Location: Georgetown, Guyana
Posts: 11,948
Gallery: 0
fordem will become famous soon enough
Default

A couple of areas to look at ...

Check the float level, make sure it's correctly set.
Check the fuel pressure, if necessary install a regulator and set to 2 psi

If the problem occurs on a slope or incline - take a look at this link...
Weber inclination stall fix
__________________
98 - 1.8 Mitsubishi Pajero iO
98 - 2.0 Suzuki Grand Vitara - SQ420
05 - 2.0 Suzuki Grand Vitara - JB420
15 - 2.4 Kia Sportage
fordem is online now   Reply With Quote Quick reply to this message
Old 03-28-2013, 10:19 PM   #6 (permalink)
Newbie
 
Join Date: Mar 2013
Location: Arizona
Posts: 19
Gallery: 0
JungleJim0745 is on a distinguished road
Default

Thanks fordem, I appreciate it and will give it a try. Can't complain about the carb when on level smooth road, seems to run much better than with the original carb but we do a lot of mountain and desert trails so the mini flooding will be a problem at times.
JungleJim0745 is offline   Reply With Quote Quick reply to this message
Old 03-29-2013, 12:10 PM   #7 (permalink)
Newbie
 
Join Date: Mar 2013
Location: Arizona
Posts: 19
Gallery: 0
JungleJim0745 is on a distinguished road
Default

Okay so this morning I called Weber Techline and the tech said he had never heard of this happening recently, and he did say they had another carb that would not do this. I talked with him about it and he said he could see how it would do the fluttering as it is called and ask me to send him an e mail when I figured out how to fix mine.

Well, went out to the shop and took the air cleaner off and looked down in the carb and for sure you can look right into the float bowl through one hole, a rectangular one almost an inch long and maybe 1/4 inch wide. I read all the fixes that I had downloaded, and decided that my new weber does not need another float bowl vent as it has a vent line going to the charcoal cannister and I started looking around my shop for something to plug that hole with. I wandered around for a few minutes looking into everything and came up with some white soft plastic commode spacers for leveling a commode on the floor. They looked about the right size so I cut the top piece off of one of them and drove it down in the carb open space over the float bowl. Of course I put one in a vat of gas first to see if gas was going to affect it adversely, and it did not. After replacing the air filter I headed for the desert and some tests. Ran on side of a long berm in the desert where we regularly target practice, leaning both directions, then went up and over the berm several times. Only a few very slight hesitations and none on the rough rocky road on the way in and I was trying to make it hesitate because it would almost quit sometimes when I went in there yesterday.

Back to the shop and checked the plastic plug, pushed it down about a 1/4 inch below the top of the carb body and filled it with Black RTV. Now retested it and no hesitation in any position. Anyone wanting pictures of the fix just let me know and give me your e mail address and I will be glad to send them. No need to pull the top off the carb, just put the plug in, and it cured the problem.

Happy Four wheeling.
JungleJim0745 is offline   Reply With Quote Quick reply to this message
Old 03-29-2013, 05:18 PM   #8 (permalink)
Moderator
 
Join Date: Mar 2009
Location: Georgetown, Guyana
Posts: 11,948
Gallery: 0
fordem will become famous soon enough
Default

You can add the pictures to the thread - I'm sure it'll help someone.
__________________
98 - 1.8 Mitsubishi Pajero iO
98 - 2.0 Suzuki Grand Vitara - SQ420
05 - 2.0 Suzuki Grand Vitara - JB420
15 - 2.4 Kia Sportage
fordem is online now   Reply With Quote Quick reply to this message
Old 03-29-2013, 10:18 PM   #9 (permalink)
Newbie
 
Join Date: Mar 2013
Location: Arizona
Posts: 19
Gallery: 0
JungleJim0745 is on a distinguished road
Default

I haven't seen where to upload pics to a thread, probably just haven't looked hard enough, will do when I figure it out.
JungleJim0745 is offline   Reply With Quote Quick reply to this message
Old 03-30-2013, 07:53 AM   #10 (permalink)
Moderator
 
Join Date: Mar 2009
Location: Georgetown, Guyana
Posts: 11,948
Gallery: 0
fordem will become famous soon enough
Default

When you're in the reply area, look for go advanced, and then manage attachments
__________________
98 - 1.8 Mitsubishi Pajero iO
98 - 2.0 Suzuki Grand Vitara - SQ420
05 - 2.0 Suzuki Grand Vitara - JB420
15 - 2.4 Kia Sportage
fordem is online now   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:13 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.