1990 Sammie newbie (no spark) - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Home Forum Active Topics Photo Gallery Garage Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
 
 
LinkBack Thread Tools
Old 02-13-2013, 09:58 PM  
Newbie
 
Join Date: Feb 2013
Posts: 1
Gallery: 0
Monroecountyboy is on a distinguished road
Exclamation 1990 Sammie newbie (no spark)

1990 Suzuki samurai jl 1.3 liter TBI.

Ladies and gents!

I just became an owner of 1990 Sammie (pops saved it from the junk yard 300 bucks)

The original owner told me that it had an electrical problem and believe me, I'm scratching my head on this one.

So let me get to the meat and potatoes: I need help tracking the root cause as to why I'm not getting fire at the plugs. I've been learning as I go so please be gentle lol! Here's the deal- no plug fire, I've bought a junk chiltons manual and have tested / replaced the ignition coil (no spark from the coil wire to the distributor). Igniter (ICM) not that! Tps swapped! not that! Missing a noise suppressor filter ( by the wiring schematics it ties the igniter, ignition coil, ECM, cluster panel together) where the heck do you get this part? Also, does this cause ignition problems? I've placed 4 new capacitors in the ECM( looked a little sketchy) I learned yesterday that this dude can retrieve codes (go figure)! The bulb was missing from the check engine light so I replaced it. When I turn the engine over with the fuse for the codes in place I receive a code 41? Ignition? Hmmm lol no sh*t but what? So I've also ran the crank angle sensor test at the ECM with a multimeter and had someone slowly turn the crank and I fluctuate between 0- 2 volts? Is that right? Does that indicate a faulty CAS? Also, if y'all think the CAS is trash how does that relate to the new coil not throwing a spark? Does the CAS have to send signal to the ecm that the engine is turning before it fires? I was expecting A LOT of juice coming from the coil and it isn't doing diddly lol. Please give me your thoughts I'm quickly surpassing the 300 bucks given for this rig and I can't seem to get the fire and you would think out of like 8 feet of harness anyone could track the issue down lol but not this guy! All the fuses have been checked and they've all checked out fine. Give me your wisdom old heads! Haha thanks! MCB
Monroecountyboy is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-13-2013, 11:10 PM  
Senior
 
Join Date: Nov 2009
Location: Mt Juliet, TN
Posts: 293
Gallery: 0
Haptown is on a distinguished road
Default

Ack's FAQ Online Search>

and enter FSM to search for the factory service manuals. You need 136 and 148. The supplemental FSM has a troubleshooting section that is quite good.
Haptown is offline   Quick reply to this message
Old 02-14-2013, 08:40 AM  
Banned
 
Join Date: Apr 2008
Location: Kansas City, MO area
Posts: 329
Gallery: 0
Skyhiranger is on a distinguished road
Default

The CAS input affects engine timing and injection pulse. So I don't see it being a problem.
When there is an ignition or fuel problem on the EFI samurais, it is usually caused by a bad ECM. I see where you replaced the capacitors, but that usually doesn't completely fix the ECM, in my experience. Usually the leaking caps damage one or more copper traces on the circuit board. So therefore those damaged traces either have to be repaired, or bypassed with a jumper wire, to get the ECM working properly again. I would go back into the ECM and test for continuity between several points around the replaced caps. The large one in the corner is the one that seems to leak the worst and damage traces. But the ones in the center of the board do/can cause issues as well.

You can also download the whole TBI supplement from....
.:Suzuki Download Archive:. Then select samurai on the left side menu, then select Suzuki Samurai TBI Supplement (it is 125M, so you better have a high speed internet connection).
The TBI supplement has diagnostic code testing procedures, misc. specs, etc. A very nice document to have, if you have a TBI (fuel injected) samurai.
Skyhiranger is offline   Quick reply to this message
Sponsored Links
Advertisement
 
 

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in

Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:55 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.