92 samurai overheating help!!! - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-05-2013, 12:32 PM   #1 (permalink)
Newbie
 
Join Date: Jul 2011
Location: St. Kitts
Posts: 12
Gallery: 0
jeremyed is on a distinguished road
Default 92 samurai overheating help!!!

Ok so here is the deal, for some reason the ol 92 Samurai is over heating and just started doing so. This is what I have done

1) It has never had a thermostat in it
2) Pulled the thermostat housing and ran the jeep while filling the radiator. At idle a low rate of fluid continuously came out.
3) Jeep off, filled the radiator, hooked back up the thermo housing and ran the jeep with the RAD cap off. Couldn't tell if there was flow or not but the lvl did not decrease by much.
4) The top hose from the engine to the RAD was hot as well as the hose from the RAD to the engine.

Here is the problem. While driving the RAD runs dry, my overflow is boiling (maybe from steam from the RAD) and the hose that comes from the overflow is steaming. Any ideas?
jeremyed is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-05-2013, 03:29 PM   #2 (permalink)
Newbie
 
anja's Avatar
 
Join Date: Sep 2011
Location: Portland, OR
Posts: 6
Gallery: 0
anja is on a distinguished road
Default

Wow! Well, first of all, why no thermostat? Second, what about the hoses into the heater core?

Have you noticed any leaking of fluid, like check around the water pump housing?

Have you noticed any white smoke coming from your exhaust? Is your Sammy burning it?
anja is offline   Reply With Quote Quick reply to this message
Old 02-05-2013, 03:42 PM   #3 (permalink)
Newbie
 
Join Date: Jul 2011
Location: St. Kitts
Posts: 12
Gallery: 0
jeremyed is on a distinguished road
Default

No thermostat because I live on a Caribbean island for the time being and you would flip your lid if you found out how much they cost, plus it is 80+ degrees year round here. A good price comparison for ya, the wheel bearing kit I got from lowrangeoffroad ~$150 US, same kit here (probably of less quality) ~$1112 US. With it running, checked for leaks around all the hoses and water pump but nothing is leaking out. I will have to look for smoke, but then again 99% of the vehicles here smoke . I try to keep mine one of the better running vehicles here
jeremyed is offline   Reply With Quote Quick reply to this message
 
Old 02-08-2013, 12:25 PM   #4 (permalink)
Senior
 
Join Date: Dec 2012
Location: New River Arizona
Posts: 173
Gallery: 0
Joe Z is on a distinguished road
Default

May be a blown head gasket and as a previous poster said to look for the white smoke "steam" also pull your four spark plugs and look at them..... If one looks way different than the others there is your problem as the water is boiling off in that cylinder. then do a compression check of those cylinders to confirm.
I'm sure you checked the oil dipstick to be sure the water isn't going into the crancase via the headgasket.
lastly you could rent a radiator compression tool w/pum and gauge that you hook to the cap on the radiator and with a cold engine pump up the tool to about 13psi and see if you can find where your losing pressure/water
Mine was giving me a lot of overheating problems and did just about what yours is doing and it turned out to be the old clutch fan was shot (when i gave mine a hand spin it would turn about a full revolution) then look down in the radiator cap and see if it looks crusty in there.... I gave mine a treatment of Prestone super flush..... now my gauge sits about 1/4 way up with a 180 degree thermost in it
Joe

Last edited by Joe Z; 02-08-2013 at 12:38 PM.
Joe Z is offline   Reply With Quote Quick reply to this message
Old 02-09-2013, 12:07 PM   #5 (permalink)
Newbie
 
Join Date: Jul 2011
Location: St. Kitts
Posts: 12
Gallery: 0
jeremyed is on a distinguished road
Default

Thanks for the replies, great things to try unfortunately at the moment the jeep is in a 3rd world country along with me so many of those things are not available. There is no water in the oil, I have checked that out and Ill have to try to find a spark plug wrench to pull those. I have been slowly driving it further distances and it doesn't seem to be doing but maybe I havent pushed it far enough yet to get it hot enough. Fluid lvls in the RAD seem a little lower than when I started but it is still full so who knows. Def bring my right hand drive sami back to the states so it can be treated properly
jeremyed is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:48 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.