Urgent Help Idling Issues - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-06-2012, 04:36 PM   #1 (permalink)
Newbie
 
Join Date: Nov 2012
Posts: 3
Gallery: 0
Zook101 is on a distinguished road
Unhappy Urgent Help Idling Issues

Hi there,

Chasing some help on my 1987 Suzuki Sierra, Wont Idle Smooth, When its cold Sits at 1000RPM Is Great Soon as it gets up to Temp Irratic and surges Between 1000RPM and 1500RPM drives fine has plenty of power soon as you put the Clutch in while driving stalls replaced all vaccum hoses checked the choke working fine swapped over EGR valve still nothing, Tested Compression 150 Over all Four Cylinders Tryed adjusting the timing Advanced 5DEG and 20 Deg before Still no good, Replaced fuel filter drained tank Pulled the plugs out All good besides Last plug closest to the Firewall Was black the rest were white. Does this Mean Valve clearenece issue???
Zook101 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-13-2012, 12:11 AM   #2 (permalink)
Newbie
 
Join Date: Nov 2012
Posts: 16
Gallery: 0
aleberro is on a distinguished road
Default

Hey im having almost the same issue with my 86 samurai: Sometiemes runs smooth and idles normally whithin the 900rpm range and after a few blocks it starts to stall (revs go down extremely fast) if not kept with the foot on the gas. Please someone with a fix help! iŽve been looking everywhere without any luck!!!
aleberro is offline   Reply With Quote Quick reply to this message
Old 11-13-2012, 12:45 PM   #3 (permalink)
Member
 
snakie's Avatar
 
Join Date: Sep 2012
Location: Cayman Islands
Posts: 48
Gallery: 0
snakie is on a distinguished road
Default

Aleberro sounds like the problem I had try adjusting the ideal. You can increase it which should raise the RPM's and keep you from stalling. I was finding regularly it was okay but when my A/C was on it died took my 2 minutes to adjust.
__________________
For step-by-step samurai/jimny instructions as I do them to my zuke look at [url]www.diyzuke.ky[/url]
snakie is offline   Reply With Quote Quick reply to this message
 
Old 11-13-2012, 02:32 PM   #4 (permalink)
Newbie
 
Join Date: Nov 2012
Posts: 16
Gallery: 0
aleberro is on a distinguished road
Default

snakie thanks for the reply but i've already tried to balance the idle in that way, it works until you get on moving and then it stalls again. There must but some problem with the carb sucking air or something. The strange thing is that in the rare cases that it idles in the first time, the revs are extremely unsettled (like if you input a little bit of gas) and when i get on moving and accelerate a bit with it everything goes back to fast dropping revs and stall issues. Its a pain in the a** having to keep the revs up with the throttle in heavy traffic or when breaking. I should probably take it to a specialized garage...
aleberro is offline   Reply With Quote Quick reply to this message
Old 11-13-2012, 02:40 PM   #5 (permalink)
Member
 
snakie's Avatar
 
Join Date: Sep 2012
Location: Cayman Islands
Posts: 48
Gallery: 0
snakie is on a distinguished road
Default

Have you checked all vacuum hoses? What RPM are you at normally and when it stalls? I find I need to keep my RPM's at minimum 1000 RPMs or it stalls.
__________________
For step-by-step samurai/jimny instructions as I do them to my zuke look at [url]www.diyzuke.ky[/url]
snakie is offline   Reply With Quote Quick reply to this message
Old 11-13-2012, 03:15 PM   #6 (permalink)
Newbie
 
Join Date: Nov 2012
Posts: 3
Gallery: 0
Zook101 is on a distinguished road
Default

ALEBERO:
I would do What Snakie said and I did replace all vaccum hoses 4mm and pulled off carby off and cleaned out the bottom Jets, Put a New fuel Filter, Drained the Tank, Put a small Filter from the outlet of the Fuel pump to intake of the carby just to be sure for $20.


One Question Is your car Surging or missing??
Zook101 is offline   Reply With Quote Quick reply to this message
Old 11-16-2012, 12:17 AM   #7 (permalink)
Newbie
 
Join Date: Nov 2012
Posts: 16
Gallery: 0
aleberro is on a distinguished road
Default

Zook101 Thanks! i will try that and post again with updates of the sami
. Thanks a lot!
aleberro is offline   Reply With Quote Quick reply to this message
Old 11-16-2012, 12:18 AM   #8 (permalink)
Newbie
 
Join Date: Nov 2012
Posts: 16
Gallery: 0
aleberro is on a distinguished road
Default

snakie thanks for the advice, iŽll try that and post updates on the problem! Thanks again!
aleberro is offline   Reply With Quote Quick reply to this message
Old 11-16-2012, 02:58 AM   #9 (permalink)
Full Member
 
Join Date: Apr 2009
Location: North Corlina
Posts: 111
Gallery: 0
Mikeww is on a distinguished road
Default

Hey guys have you pulled the top off your carbs and cleaned all the jets and passages inside? That's what I just had to do to mine. It runs much better now (wouldn't idle at all and had poor acceleration) the inside wasn't real dirty but the accelerator pump nozzle was completely stopped up.

Mike
__________________
1994 Geo Tracker 2 door tin top, 1.6 L with 8V, TBI, Automatic transmission and 4WD, AC***TOTALED***:(
Looking for my next Toad.
Got it.
1987 Suzuki Samurai, 1.3L, bone stock,:D
Mikeww is offline   Reply With Quote Quick reply to this message
Old 11-16-2012, 10:41 AM   #10 (permalink)
Newbie
 
Join Date: Nov 2012
Posts: 16
Gallery: 0
aleberro is on a distinguished road
Default

Hey Mikeww i will look into that as well, i have another question: i have the stock carb on my sami, when passing 3500-4000rpm the engine stops pulling hard and drops a bit (like if it was drowning and then starts pulling again. It seems to be the second carb "chamber" opening, but im not sure, do you know how to tune that up?
aleberro is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:05 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.