87 samurai blower motor - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-12-2012, 05:13 AM   #1 (permalink)
Newbie
 
Join Date: Aug 2012
Posts: 4
Gallery: 0
EnigmaticMindx is on a distinguished road
Default 87 samurai blower motor

Hi, i recently purchased an 87 sami and when i tried to turn the heat on nothing happened. A buddy of mine banged on this little box that is mounted underneath the dash on the passenger side from the inside of the vehicle and the blower started makin some crazy sounds, but still not blowing anything.

I looked online and saw to drill a whole and clean out all of the crap from above the heater core or whatever.. I did that and it was all plugged up. I plugged the hole back up and flipped on the heater and same crazy loud bzzclunkzzchickbzz noise. No air flow out of the vents whatsoever.

So my question is, does that box sound like it needs replacing? and what is it? Or does it sound like my blower motor is bad? Or could it be something else? Fall is creeping up on us and i live in upstate ny and would like to get some heat pumping so that i don't have to roll around all winter in a snowmobile suit. Thanks
EnigmaticMindx is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-12-2012, 10:50 PM   #2 (permalink)
Member
 
Join Date: Apr 2012
Location: madera california
Posts: 80
Gallery: 0
rey0176 is on a distinguished road
Default

well i would check the easy things like fuse.and make sure you have power to the dash switch. if thats all good, make sure you got power to the blower motor. maybe the sound you hear its trying to spin and may be debri inside of the blower motor.blow it out or vacumm it out.im not sure if they have a relay also.but if you have power to your switch,fuse,and blower harness then i would say the relay is good.also make sure the hoses to the heater are connected for coolant.you may want to bypass the heater control valve and connect it direct to the heater coil.they tend to leak like mine was and you get less heat and longer to get hot.
rey0176 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:19 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.