99 Jimny engine problem 2000-3000rpm - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Home Forum Active Topics Photo Gallery Garage Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
 
 
LinkBack Thread Tools
Old 05-07-2012, 12:20 AM  
Newbie
 
Join Date: Oct 2011
Location: Queensland, Australia
Posts: 11
Gallery: 0
J.R. is on a distinguished road
Default 99 Jimny engine problem 2000-3000rpm

Hi everyone.

Here's my problem. I was driving down the road on my way out of town when my tacho all of a sudden started to have a spaz atack. when I reached 80kmh, and around 3000rpm, the tacho started to flicker nearly to no revs, and then come back to normal. the engine would also 'kick in' when the revs came back to normal. after a few times of this, the engine revs went to 0, and the engine stopped with the engine check light on.

After a minute, i was able to start the jimny again, and I thought that I would just drive it slow, but the same thing would happen anywhere between 2000, and 3000rpm. I also had to continue to wait for a minute before I could start up again.

I thought that it might be a fuel filter/pump problem because I had just filled up with fuel, so I am in the process of replacing the pump assembly. but I also have read that jimny's can have camshaft sensor problems. (I have a G13BB engine, so no crankshaft sensor.) Does this sound like a more plausible cause for my engine malfunction? Any other suggestions would be helpful. I have a 1300km round trip coming up in 2 weeks so I would like to have my jimny running with no problems by then.
J.R. is offline   Quick reply to this message
Sponsored Links
Advertisement
 
Old 05-09-2012, 08:50 AM  
Guest
 
Join Date: Jun 2008
Location: The Kingdom of England
Posts: 5,299
Gallery: 5
Rhinoman is on a distinguished road
Default

It sounds like a camshaft sensor problem. If it was fuel related then the rev counter would still report how many RPM the engine was doing rather than cutting instantly.
Rhinoman is offline   Quick reply to this message
Sponsored Links
Advertisement
 
 

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in

Thread Tools

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:37 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.