Missing vacuum lines on 1.3 swapped carb - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-06-2012, 11:05 PM   #1 (permalink)
Member
 
Join Date: Aug 2011
Posts: 47
Gallery: 0
BrendenV is on a distinguished road
Default Missing vacuum lines on 1.3 swapped carb

I recently bought a 1987 samurai with the stock 1.3l engine and from why the previous owner told me the carburetor was changed but he said it was an off brand from eBay and didn't know what kind it was. I can post pics soon. I noticed a lot of vacuum lines are missing and that concerns me because the engine idles really rough at start up and smokes which leads me to believe the engine is running rich. The exhaust smells like gas and it leaks into the cabin which bothers me for not only the smell but the safety issue of breathing tht in for long periods of time.

Now before I go tinkering with idle adjustment screws I'd like to fix the vacuum lines and see if 1 that helps with the richness of the mixture and 2 the rough idle at start up.

I've read and tried to decipher the picture of the vacuum diagram under the hood and I've read acks FAQ 2-4 times but I just don't understand it and it seems like everything in the diagrams and pictures is from a completely different engine. Nothing is in the same place and I'm not farmiliar with the different sensors.

Please can someone dumb this down for me or help me find where I can find the answer.
BrendenV is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-08-2012, 10:23 AM   #2 (permalink)
Member
 
Join Date: Aug 2011
Posts: 47
Gallery: 0
BrendenV is on a distinguished road
Default

Here's the pics:





BrendenV is offline   Reply With Quote Quick reply to this message
Old 04-09-2012, 12:11 PM   #3 (permalink)
Member
 
Join Date: Aug 2011
Posts: 47
Gallery: 0
BrendenV is on a distinguished road
Default

Come on guys I know someone here has the ability to look and compare engines to help me figure out what lines go where.
BrendenV is offline   Reply With Quote Quick reply to this message
 
Old 04-09-2012, 03:25 PM   #4 (permalink)
Senior
 
Azelgin's Avatar
 
Join Date: Oct 2010
Location: S. E. Arizona
Posts: 264
Gallery: 0
Azelgin is on a distinguished road
Default

If it no longer has the stock carb and emisson control system componets in place, there is really no way to figure out what is supposed to go where. I can tell from your pictures that one missing item is the stock air cleaner, which had an air temperature intake control. You are also missing a vacuum line to the EGR valve. Here is a good guide for figuring out what a stock system should look like and trouble shooting.

http://zukioffroad.com/Tech_Library/...ons_manual.pdf
Azelgin is offline   Reply With Quote Quick reply to this message
Old 04-10-2012, 12:35 AM   #5 (permalink)
Member
 
Join Date: Aug 2011
Posts: 47
Gallery: 0
BrendenV is on a distinguished road
Default

If I find out what carb I have will that help or is it still just a crap shoot at this point. From reading that link that was really helpful by the way I suspect the egr valve is missing a vacuum line causing my rough idle at start up and the fuel smell in the exhaust. If finding out which carb it is will help how can I tell which one it is? I'm fairly certain its not a weber carb but ill have to try taking it off for inspection of the internals.
BrendenV is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:21 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.