Fuel FAIL! :o( - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-10-2012, 07:42 PM   #1 (permalink)
Newbie
 
Join Date: Mar 2012
Posts: 5
Gallery: 0
subperceptual is on a distinguished road
Unhappy Fuel FAIL! :o(

Hey all - I have an 88 Sam which is driving me up the wall. Hopefully one of you will have some idea what might be happening. Before I say what it is (not) doing, let me say what has been done...

1. Dropped, cleaned, vetted tank....
2. blew all lines back
3. new lines; return, feed, can, separator, blah blah blah
4. new fuel filter
5. new cap
6. New canister

... no bueno ... I am not getting fuel at all ... not on the manual pump, not on electric inline, not with cap off (suspecting vacuum). If I blow air from engine back to tank, I can hear air pressure build in the tank ("thud") and I get a short (good) stream of fuel all the way up. These were the symptoms I had which provoked me to clear the tank and lines to begin with. It had been running fine with no issues.. went to start cleaning it out... then whammo... no fuel. The sammy had sat for some time and the tank was tarnished heavily, a lot of crud - so I figured it was getting clogged at the return or feed and decided to clean the whole tank. Now that I am confident it is clean, cleared, with all fresh hardware and rubber, I am at a complete loss as to what is going on.


Any good suggestions? )

Thanks in advance.
subperceptual is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-11-2012, 08:03 AM   #2 (permalink)
Moderator
 
Join Date: Mar 2009
Location: Georgetown, Guyana
Posts: 11,958
Gallery: 0
fordem will become famous soon enough
Default

What's the possibility that you have two defective pumps - or - a defective mechanical pump and an inproperly mounted inline electric?

Two things - if blowing air back to the tank results in a thud and then a brief flow of fuel it's an indication of (a) possibly improper venting and (b) that you have fuel in the tank and a clear (unblocked) delivery pipe - since you have removed the cap to prevent a vacuum build up, we can eliminate (a) as the primary problem, so we must look to see why the pump(s) are not drawing fuel.

Please note - I have describe (a) as "possibly improper venting" - fuel tank vent systems have changed over the years, and can differ for different markets due to regulation specifics - your vehicle may have a vapor recovery system, which would case it to act as you describe.
__________________
98 - 1.8 Mitsubishi Pajero iO
98 - 2.0 Suzuki Grand Vitara - SQ420
05 - 2.0 Suzuki Grand Vitara - JB420
15 - 2.4 Kia Sportage
fordem is offline   Reply With Quote Quick reply to this message
Old 03-11-2012, 08:52 AM   #3 (permalink)
Newbie
 
Join Date: Mar 2012
Posts: 5
Gallery: 0
subperceptual is on a distinguished road
Default

Fordem.... I am confident that the inline electrical was mounted properly and functioning (drew gas from a can to prime it before hooking line to tank). The mechanical... could be questioned (never trust a brown box pump... lol). I am questioning tank venting, I suspect the return line - though I can declare the line to tank is clear... the line on tank I am now concerned about. The line to the seperator I am certain is good .... which leaves the line to the charcoal canister. Could it be the line/charcoal canister? Hmmmmm.

I am going to test the pumps again, and possibly drop the tank to double check the return on tank. I assumed the action of the mechanical pump to return displaced air and fuel via the return line might be the issue.... if anyone can shed light on its role, that would be appreciated.

I will test the pumps again and go over the charcoal canister and report back.
subperceptual is offline   Reply With Quote Quick reply to this message
 
Old 03-11-2012, 11:07 AM   #4 (permalink)
Moderator
 
Join Date: Mar 2009
Location: Georgetown, Guyana
Posts: 11,958
Gallery: 0
fordem will become famous soon enough
Default

How about a divide & conquer approach ...

Start with the minimum - the tank with fuel inside and the cap off (to prevent a vacuum build up), electric inline pump, connected to the tank (presumably via a filter), and a line from the pump outlet to a can - power up the pump from a 12v source and fuel should flow.

If there is no fuel flow, you should be able rapidly isolate the problem - tank, filter, pump lines.

If this works re-connect the delivery line leading to the front of the car and disconnect where it attaches to the carburettor and make sure you get fuel delivered there.

If you get this far, reconnect the pump to the "normal" power source - if there is no fuel now, the problem will be electrical.
__________________
98 - 1.8 Mitsubishi Pajero iO
98 - 2.0 Suzuki Grand Vitara - SQ420
05 - 2.0 Suzuki Grand Vitara - JB420
15 - 2.4 Kia Sportage
fordem is offline   Reply With Quote Quick reply to this message
Old 03-11-2012, 12:20 PM   #5 (permalink)
Newbie
 
Join Date: Mar 2012
Posts: 5
Gallery: 0
subperceptual is on a distinguished road
Default

Well ... tried a second elect pump inline from directly off the tank feed ... maybe six inches with 2.5 -5 lbs of pull ... nadda ... pump was moving air disconnected and nothing connected ... I am going to assume a blockage in tank, pull and go over it again.

I will report back.
subperceptual is offline   Reply With Quote Quick reply to this message
Old 03-11-2012, 12:32 PM   #6 (permalink)
Senior
 
zooki4x4's Avatar
 
Join Date: Aug 2009
Location: Laurel Fork, VA
Posts: 150
Gallery: 0
zooki4x4 is on a distinguished road
Default

The pickup tube in the tank might have a pin hole rusted near the top of it. It will suck air and no fuel.
zooki4x4 is offline   Reply With Quote Quick reply to this message
Old 03-11-2012, 12:53 PM   #7 (permalink)
Newbie
 
Join Date: Mar 2012
Posts: 5
Gallery: 0
subperceptual is on a distinguished road
Default

Quote:
Originally Posted by zooki4x4 View Post
The pickup tube in the tank might have a pin hole rusted near the top of it. It will suck air and no fuel.
Inside or out?

I didn't even consider that - maybe plug up tank and blow air through return? If it has a leak in the pickup tube on the outside I would hear it lose pressure... right? and if I try to pull directly from the tank with the whole thing sealed I would hear it suck air with no fuel pull... right?
subperceptual is offline   Reply With Quote Quick reply to this message
Old 03-11-2012, 12:57 PM   #8 (permalink)
Newbie
 
Join Date: Mar 2012
Posts: 5
Gallery: 0
subperceptual is on a distinguished road
Default

The only thing that sticks out in my mind if it did have a hole in the pickup is the fact that I can blow air into the tank from the feed line, and I will hear a distinctive thud indicating pressure in the tank... and then fuel will pressure feed back up through the line until the pressure becomes equal again.... is it possible that it is simply "enough" pressure forcing it through regardless of leak?
subperceptual is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:32 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.