1986 samurai - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-25-2011, 06:07 PM   #1 (permalink)
Newbie
 
Join Date: Jun 2011
Posts: 1
Gallery: 0
Jpurcell_20 is on a distinguished road
Default 1986 samurai

I have an 86 samurai that starts and idles fine. But when I start to give it fuel it wants to die, and sputters bad when driving. I've done numours things I've changed the fuel filter, spark plugs, air filter, drained the gas tank, and cleaned the top part of carb. Anyone have any ideas?
Jpurcell_20 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-26-2011, 07:17 AM   #2 (permalink)
Newbie
 
RStorman's Avatar
 
Join Date: Jun 2011
Posts: 3
Gallery: 0
RStorman is on a distinguished road
Default

#1 Is your ignition timing set correctly? 10-degress BTDC @ 800RPM (some folks on this forum say it runs better at 8-degrees BTDC). Also, is your timing belt worn?

Others:
Vacuum Leak - Do you hear a hissing sound when listening close to the engine?

Spark Plugs - Correct type (NGK BPR-5ES), and correct gap (.028 - .031). Also, consider replacing the plug wires and distributor cap.

Fuel Pump - Defective pump, leaky pump, or leaky hoses (mechanical pump is mounted on right rear corner of the cylinder head on carbureated Samurai's)

Carburetor - Misadjusted or choke/linkage is sticking
RStorman is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:02 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.