Engine? noise! - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-18-2011, 04:39 AM   #1 (permalink)
Newbie
 
Join Date: Mar 2010
Posts: 19
Gallery: 0
Ben2010 is on a distinguished road
Unhappy Engine? noise!

Hi Guys, today my car is making a loud rattling noise? it's most evident in low revs. I first thought it was low on oil (as the sound was similar to that?), but this was not the case after checking oil level. It drives well, through out gear range, but the nise at low revs is very concerning. Any ideas would be greatly appreciated.
Ben2010 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-18-2011, 09:11 AM   #2 (permalink)
Senior
 
VaderSS's Avatar
 
Join Date: May 2010
Location: Cordelia, CA
Posts: 328
Gallery: 0
VaderSS is on a distinguished road
Garage
Default

Check your exhaust system. If it has anything loose or is making contact anywhere, it can make noises that sound like the Sami is trying to destroy itself.
__________________
Wayne Bengston
'88.5 Samurai JX, mostly stock
VaderSS is offline   Reply With Quote Quick reply to this message
Old 06-19-2011, 08:55 PM   #3 (permalink)
Newbie
 
Join Date: Mar 2010
Posts: 19
Gallery: 0
Ben2010 is on a distinguished road
Default

Thanks for repley. Checked exhaust and fittings, all good. The engine sounds like marbles rattling around in a can or when you vacuum up some metal objects in the hoover???

The car drives well and no loss in power? just heavy rattling in low gear/low revs???

Do you think it could be something as simple as fuel quality or changing spark plugs and oil/filter change?
Ben2010 is offline   Reply With Quote Quick reply to this message
 
Old 06-19-2011, 11:29 PM   #4 (permalink)
Senior
 
VaderSS's Avatar
 
Join Date: May 2010
Location: Cordelia, CA
Posts: 328
Gallery: 0
VaderSS is on a distinguished road
Garage
Default

Usually detonation is not that loud. Check your timing to ensure it is not advanced from the correct setting. You can try running premium gasoline to see if the noise goes away or is reduced, which would indicate detonation. Detonation can be caused by advance timing or excess carbon deposits in the combustion chamber.

Keep in mind that the exhaust may not contact anything at rest, but may contact something when the drive-train is putting out a lot of torque. Mine contacts the bumper under hard acceleration in first.

Another thing to check is your motor, transmission mounts, and transfer case mounts. If they have deteriorated, they may be letting the attached unit move too much, make metal to metal contact, or cause the exhaust to make metal to metal contact.
__________________
Wayne Bengston
'88.5 Samurai JX, mostly stock
VaderSS is offline   Reply With Quote Quick reply to this message
Old 06-23-2011, 08:28 AM   #5 (permalink)
Newbie
 
Join Date: Mar 2010
Posts: 19
Gallery: 0
Ben2010 is on a distinguished road
Thumbs up Noise from engine resolved!!

Hi Wayne, thanks for your input.

I had a look again and found a lower bolt missing on the mounting bracket for the alternator?? missing...I removed the belt, fired up the engine and the sound was gone!!!! who would of thought, an ALTERNATOR would make such a loud and concerning sound...still, very gratefull, that's all it was....ben2010
Ben2010 is offline   Reply With Quote Quick reply to this message
Old 06-23-2011, 09:32 AM   #6 (permalink)
Senior
 
VaderSS's Avatar
 
Join Date: May 2010
Location: Cordelia, CA
Posts: 328
Gallery: 0
VaderSS is on a distinguished road
Garage
Default

Yuppers. Anything that can move can move in a way it was not meant to can cause some loud noises.

As for seemingly unrelated stuff, I spent a year putzing with my carb trying to get it to idle, and finally put a new one in. Turned out it was a loose ECM ground. Now I need to put the old carb in because it ran better with that carb, except for the idle!
__________________
Wayne Bengston
'88.5 Samurai JX, mostly stock
VaderSS is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 02:16 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.