HELP Someone PLEASE!!!! - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-28-2011, 08:30 AM   #1 (permalink)
Member
 
Join Date: Sep 2009
Location: albuquerque nm
Posts: 71
Gallery: 0
SAMMYJAMMY is on a distinguished road
Default HELP Someone PLEASE!!!!

I put a new alternator and new battery and now the battery light is on with the park light, and the sensor light any clues.
SAMMYJAMMY is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-28-2011, 09:33 PM   #2 (permalink)
Member
 
Join Date: Sep 2009
Location: albuquerque nm
Posts: 71
Gallery: 0
SAMMYJAMMY is on a distinguished road
Default

Help me please
SAMMYJAMMY is offline   Reply With Quote Quick reply to this message
Old 03-01-2011, 12:59 AM   #3 (permalink)
Banned
 
Join Date: Feb 2011
Posts: 10
Gallery: 0
billlikecar is on a distinguished road
Default

don't really know waht you want to ask...
billlikecar is offline   Reply With Quote Quick reply to this message
 
Old 03-01-2011, 04:07 PM   #4 (permalink)
Veteran
 
Join Date: Sep 2008
Location: El Paso, Texas
Posts: 1,862
Gallery: 2
Billjohn is on a distinguished road
Default

Check your connections.
I don't think it is possible to plug the alt in backwards, but it doesn't seem like the system is seeing all the parts...

Another thing to check is the white wire from the battery. It is a fusable link that can burn out if there was an electrical problem. Check to see if there isn't a burn mark or a soft spot in it. If you have a meter, heck it for continuity.
__________________
Bill
in old El Paso...
Billjohn is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:36 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.