geaebox problems - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-19-2011, 03:17 AM   #1 (permalink)
Full Member
 
Join Date: Jan 2011
Location: Darwin N.T.
Posts: 105
Gallery: 5
lokdzuk is on a distinguished road
Garage
Post geaebox problems

i got a 93 sierra 1.3 aus version of samuria when i change into 5th it wont hold 100kph slows down to about 90kph 4th will go to 120kph anyone with any ideas.
lokdzuk is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-19-2011, 07:34 PM   #2 (permalink)
Senior
 
Azelgin's Avatar
 
Join Date: Oct 2010
Location: S. E. Arizona
Posts: 264
Gallery: 0
Azelgin is on a distinguished road
Default

Drive slower? Mine scares the hell out of me at 75mph!
Azelgin is offline   Reply With Quote Quick reply to this message
Old 01-19-2011, 10:51 PM   #3 (permalink)
Member
 
Puddlejumper's Avatar
 
Join Date: Jan 2011
Location: Cypress,Tx
Posts: 33
Gallery: 0
Puddlejumper is on a distinguished road
Default

Based on the information you have given, replace your fuel filter.
Puddlejumper is offline   Reply With Quote Quick reply to this message
 
Old 01-20-2011, 02:01 AM   #4 (permalink)
Full Member
 
Join Date: Jan 2011
Location: Darwin N.T.
Posts: 105
Gallery: 5
lokdzuk is on a distinguished road
Garage
Default

i replaced the fuel filter a couple of weeks ago and that didn't change any thing im thinking that its got something to do with the carby
lokdzuk is offline   Reply With Quote Quick reply to this message
Old 01-20-2011, 08:45 AM   #5 (permalink)
Veteran
 
Join Date: Sep 2008
Location: El Paso, Texas
Posts: 1,862
Gallery: 2
Billjohn is on a distinguished road
Default

Quote:
Originally Posted by Azelgin View Post
Drive slower? Mine scares the hell out of me at 75mph!
100 KPH = about 62 mph
__________________
Bill
in old El Paso...
Billjohn is offline   Reply With Quote Quick reply to this message
Old 01-20-2011, 09:00 AM   #6 (permalink)
Senior
 
Azelgin's Avatar
 
Join Date: Oct 2010
Location: S. E. Arizona
Posts: 264
Gallery: 0
Azelgin is on a distinguished road
Default

Quote:
Originally Posted by Billjohn View Post
100 KPH = about 62 mph
Yea, I know. Says he gets it up to 120 in 4th. My old Owners manual recommends a maximum speed of 55MPH. Not saying that's what I drive, but, they're not exactly a sports car.

Last edited by Azelgin; 01-20-2011 at 09:04 AM.
Azelgin is offline   Reply With Quote Quick reply to this message
Old 01-20-2011, 09:19 AM   #7 (permalink)
Veteran
 
Join Date: Jan 2008
Location: San Diego, CA
Posts: 1,230
Gallery: 0
Baratacus is on a distinguished road
Default

there is a switch on the U.S. models, don't know if the AUS models have it. It's on the transmission. When you shift into 5th gear then it shuts off the EGR system. The engine doesn't put out enough power to use 5th gear with the EGR system engaged. Might be worth looking into. 5th gear is really pushing the limits of the 1.3 engine, so little things can add up enough to make it non-useable. worn Universal joints, wheel bearings, over sized tires.... any and all of these can make it labor hard, and a combination of them could put it's dork in the dirt. Make sure you get the power issue worked out, then you might look into some preformance mods for it, but don't start on the preformance mods untill you get the original issue fixed. Otherwise you're just covering up a problem that will continue to get worse and wreck other things on the vehicle.
Baratacus is offline   Reply With Quote Quick reply to this message
Old 01-21-2011, 02:35 AM   #8 (permalink)
Full Member
 
Join Date: Jan 2011
Location: Darwin N.T.
Posts: 105
Gallery: 5
lokdzuk is on a distinguished road
Garage
Default

thanks for the info on the egr i'll have a look when i get home in a weeks time. ive had the engine rebuilt with all race parts and had a port & polish done on it and crank shft balance i also run a 2 inch mandrel bent exhaust with extractors and a snorkel for the inbound air
lokdzuk is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:43 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.