1995 vitara 4th injector not firing - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-19-2010, 09:04 PM   #1 (permalink)
Newbie
 
Join Date: Nov 2010
Posts: 3
Gallery: 0
missjodyleigh is on a distinguished road
Smile 1995 vitara 4th injector not firing

Hi there everyone
I have a 1995 vitara and the 4th injector is not firing.
Have checked:
- computer
- coil
- timing
- compression test

Anyone have any ideas please?
Thanks so much
missjodyleigh is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-19-2010, 09:10 PM   #2 (permalink)
Newbie
 
Join Date: Nov 2010
Location: michigan
Posts: 21
Gallery: 0
CHEVYDUALLY is on a distinguished road
Default

how u know #4 injetor not firing, u can take a noide light or a 194 bulb and connect to #4 injector and start car the light should flicker on and off at moderte pace if it goes injector has power
CHEVYDUALLY is offline   Reply With Quote Quick reply to this message
Old 11-20-2010, 01:54 AM   #3 (permalink)
Newbie
 
Join Date: Nov 2010
Posts: 3
Gallery: 0
missjodyleigh is on a distinguished road
Default

I've had my car at 3 different mechanics and two of them have told me that the 4th injector is not firing. The 1st mechanic didn't know what was wrong with it. Nobody seems to be able to fix it.
missjodyleigh is offline   Reply With Quote Quick reply to this message
 
Old 11-20-2010, 03:27 AM   #4 (permalink)
Newbie
 
Join Date: Nov 2010
Posts: 3
Gallery: 0
missjodyleigh is on a distinguished road
Default

I am new to this site and don't know if I asked this qu in the right thread??
Any advice would be appreciated.
Thanks
missjodyleigh is offline   Reply With Quote Quick reply to this message
Old 11-20-2010, 03:50 PM   #5 (permalink)
Member
 
Join Date: Feb 2010
Location: Black Hills, South Dakota
Posts: 28
Gallery: 0
TKBruce is on a distinguished road
Default

Actually, you are in the Samurai thread, so you probably won't get an answer here!
TKBruce is offline   Reply With Quote Quick reply to this message
Old 11-20-2010, 08:38 PM   #6 (permalink)
Veteran
 
Join Date: Jan 2008
Location: San Diego, CA
Posts: 1,230
Gallery: 0
Baratacus is on a distinguished road
Default

neither the coil, the timing, or the compression have anything to do with your injector not working. Is the plug not firing or is the injector not injecting fuel into the cylinder? If it's the injector, then you need to determine if the injector is getting a signal. If it's not getting a signal then you most likely have a shorted or grounded wire from the ecU to the injector. If it IS getting a signal but not functioning then you need to replace the injector. I don't know why one of your 3 mechanics wouldn't have told you that.
Baratacus is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:45 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.