no turn signals front/rear & no wipers - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-29-2010, 07:51 PM   #1 (permalink)
Member
 
NigelAloha's Avatar
 
Join Date: Sep 2010
Location: Maui, Hawaii
Posts: 93
Gallery: 0
NigelAloha is on a distinguished road
Default no turn signals front/rear & no wipers

signals were working fine then nothing.
wipers went on for a second then died and got stuck halfway on the window.
any suggestions?
NigelAloha is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-20-2010, 04:02 AM   #2 (permalink)
Member
 
NigelAloha's Avatar
 
Join Date: Sep 2010
Location: Maui, Hawaii
Posts: 93
Gallery: 0
NigelAloha is on a distinguished road
Default

signals will work sometimes...
wipers are dead...
NigelAloha is offline   Reply With Quote Quick reply to this message
Old 10-20-2010, 12:38 PM   #3 (permalink)
Full Member
 
Join Date: Mar 2010
Location: USA
Posts: 123
Gallery: 0
texastintop is on a distinguished road
Default

I would start by taking it apart, check all the pigtails for proper connection, check the ground make sure the screw didnt rattle out. See if its getting power to the swith.
texastintop is offline   Reply With Quote Quick reply to this message
 
Old 10-20-2010, 01:45 PM   #4 (permalink)
Veteran
 
Join Date: Jan 2008
Location: San Diego, CA
Posts: 1,230
Gallery: 0
Baratacus is on a distinguished road
Default

good chance that you have a loose or corroded connection in your steering column. Check the multi switches in the turn signal and the wiper controler, check the wire loom and connector for loose or shorted contacts.
Baratacus is offline   Reply With Quote Quick reply to this message
Old 10-20-2010, 09:33 PM   #5 (permalink)
Senior
 
Join Date: Mar 2010
Posts: 212
Gallery: 0
arlo is on a distinguished road
Default grounded right

Check all the grounds or the individual lights.
Check the plug in the steering column, under the bezel, near the dash.
Check the mounting of the wipers on the windshield.
Have you checked the fuses ?
IF it ever works it should work again.
If it stops and never starts again that is trouble. (read replace)
But sounds more like a ground (earth) issue.
You may be able to attach 12 volts to the wire to the wipers to bypass the switch...that will tell u if they will operate at all.
You can feed 12 volts to the individual lights to check them...if they light it is at or near the switch.
arlo is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:41 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.