samurai just died - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-12-2010, 03:02 PM   #1 (permalink)
Newbie
 
Join Date: Sep 2010
Location: Orange County, CA
Posts: 16
Gallery: 0
gmwill29 is on a distinguished road
Angry samurai just died

i was sitting at a light and the engine just completely died. i tried starting it and it just kept clicking and wanted to turn but it didnt. i replaced the coil but it still does the same thing. all the electronics work but i cant find anything on the web about how to fix it. whats happening?
gmwill29 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-12-2010, 03:15 PM   #2 (permalink)
Senior
 
zooki4x4's Avatar
 
Join Date: Aug 2009
Location: Laurel Fork, VA
Posts: 150
Gallery: 0
zooki4x4 is on a distinguished road
Default

Sounds like you need the clickity starter fix. Lots of info on the board about how to do it. Not sure why it just died tho.
zooki4x4 is offline   Reply With Quote Quick reply to this message
Old 09-12-2010, 03:28 PM   #3 (permalink)
Newbie
 
Join Date: Sep 2010
Location: Orange County, CA
Posts: 16
Gallery: 0
gmwill29 is on a distinguished road
Default

i took out a spark plug to see if it was getting any spark but nothing was happening. it sounds like it wants to turn but it doesnt
gmwill29 is offline   Reply With Quote Quick reply to this message
 
Old 09-12-2010, 04:33 PM   #4 (permalink)
Member
 
Join Date: Mar 2010
Location: Lenoir, NC
Posts: 28
Gallery: 0
Daletec is on a distinguished road
Default

Yep, no point in checking spark plugs until you get the engine turning over. Perform the Clickety Fix for your starter, it should start right up.
Daletec is offline   Reply With Quote Quick reply to this message
Old 09-12-2010, 04:49 PM   #5 (permalink)
Senior
 
zooki4x4's Avatar
 
Join Date: Aug 2009
Location: Laurel Fork, VA
Posts: 150
Gallery: 0
zooki4x4 is on a distinguished road
Default

You can use a jumper wire to test the starter. Just put everything in nutral and scotch the wheels park brake on. With the switch on take a 2' wire and touch the + pos terminal on the battery with one end and touch the other to the bottom wire on the starter. If it turns over or fires you need the clickity fix. Please be safe doing this.
zooki4x4 is offline   Reply With Quote Quick reply to this message
Old 09-12-2010, 05:49 PM   #6 (permalink)
Veteran
 
Join Date: Sep 2008
Location: El Paso, Texas
Posts: 1,862
Gallery: 2
Billjohn is on a distinguished road
Default

Here is what they are talking about...
Clicky Starter Fix
__________________
Bill
in old El Paso...
Billjohn is offline   Reply With Quote Quick reply to this message
Old 09-12-2010, 06:16 PM   #7 (permalink)
Member
 
Join Date: Aug 2009
Location: N.E.Texas
Posts: 73
Gallery: 0
GIZMO is on a distinguished road
Default

I'm speaking from past experience.....it could be that the altenator has stopped charging an the battery ran the engine as long as it could and the engine died. The battery is dead and that is why it will not turn over (crank). You haven't said that you tried to jump-start said engine with another auto. If it does start and you disconnect the jumper cables....to see if the alt is charging and supplying the system with power for the coil...loosen and remove the positive cable on the battery. If the engine continues to run the alt is ok.



GIZMO
GIZMO is offline   Reply With Quote Quick reply to this message
Old 09-12-2010, 06:26 PM   #8 (permalink)
Newbie
 
Join Date: Sep 2010
Location: Orange County, CA
Posts: 16
Gallery: 0
gmwill29 is on a distinguished road
Default

it is definately not a starter issue it wants to start with no problem but its not turning over. the battery is fine and the alternator is fine its just not wanting to turn. it died at a complete stop and wouldnt start up again.

Last edited by gmwill29; 09-12-2010 at 08:36 PM.
gmwill29 is offline   Reply With Quote Quick reply to this message
Old 09-13-2010, 06:45 AM   #9 (permalink)
Member
 
Join Date: Mar 2010
Location: Lenoir, NC
Posts: 28
Gallery: 0
Daletec is on a distinguished road
Default

If it's not turning over, but you hear a clicking noise, then not enough power is getting to the starter to completely engage the gear or turn the motor. We're not saying the starter is bad, just not getting enough power.
Daletec is offline   Reply With Quote Quick reply to this message
Old 09-24-2010, 03:09 PM   #10 (permalink)
Member
 
Join Date: Aug 2009
Location: N.E.Texas
Posts: 73
Gallery: 0
GIZMO is on a distinguished road
Default

gmwill29........what ever became of this problem? I see that you want to replace the engine in a later thread. What did you find out?





GIZMO
GIZMO is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:58 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.