Samurai 93 Cooling Problem - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-28-2010, 06:05 PM   #1 (permalink)
Newbie
 
Join Date: Dec 2009
Location: PUERTO RICO
Posts: 2
Gallery: 0
RAFA056 is on a distinguished road
Default Samurai 93 Cooling Problem

Hi , My samurai 93 have problem cooling system . no mix oil/water , i change water pump , thermo , rad cap ( parts oem suzuki ) . the radiator is aluminum new (buy last year) , timing ok 8* , ignition ok , i flush system .
temp up over 200* in road 20-45 mph , over 55- 65 mph temp low little . the system have 2 sender temp , one oem other autometer gauge , both same read .
RAFA056 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-28-2010, 08:14 PM   #2 (permalink)
Senior
 
zooki4x4's Avatar
 
Join Date: Aug 2009
Location: Laurel Fork, VA
Posts: 150
Gallery: 0
zooki4x4 is on a distinguished road
Default

My guess would be that your fan is slipping. At the higher road speeds the air flow through the radiator keeps it cooler without the fans help.
zooki4x4 is offline   Reply With Quote Quick reply to this message
Old 08-30-2010, 09:38 AM   #3 (permalink)
Senior
 
Join Date: Mar 2009
Location: 2Close2LA
Posts: 193
Gallery: 8
Merlin93 is on a distinguished road
Default

When my stock 93 Samurai motor overheated on the trail at low speeds, I thought the fan clutch was slipping and replaced it. It's a common failure and easily replaced. No more low speed overheating now. They can be hard to test accurately. Mine lasted about 15 years.
Merlin93 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 11:48 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.