G13a Idle + Distributor - Urgent Assitance Required - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-18-2010, 08:23 PM   #1 (permalink)
Newbie
 
jemthejem's Avatar
 
Join Date: May 2010
Posts: 7
Gallery: 0
jemthejem is on a distinguished road
Default G13a Idle + Distributor - Urgent Assitance Required

Hey Guys,

Need some urgent advice please.

Just changed timing belt and flushed radiator, car was running like an absolute dream however the idle was quite high when we finished.

After playing with idle adjust screw with no luck we adjusted distributor slightly which brought idle down to 900rpm, I thought the problem was solved.

However after driving for a little while idle climbs back up to 1500rpm can somebody pls advise what this could possibly be?

Car started fine this morning, but upon idleing she cut out and I couldn't restart her and had to get a lift to work. Is this because i moved the distributor??

Somebody please help !!
jemthejem is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-18-2010, 10:28 PM   #2 (permalink)
Senior
 
Join Date: Nov 2009
Location: Mt Juliet, TN
Posts: 293
Gallery: 0
Haptown is on a distinguished road
Default

Absolutely, positively sure that you didn't disturb any vacuum lines? This is the most likely cause if it continues to idle high after warm up.

Last edited by Haptown; 07-18-2010 at 10:45 PM.
Haptown is offline   Reply With Quote Quick reply to this message
Old 07-18-2010, 10:41 PM   #3 (permalink)
Newbie
 
jemthejem's Avatar
 
Join Date: May 2010
Posts: 7
Gallery: 0
jemthejem is on a distinguished road
Default

Quote:
Originally Posted by Haptown View Post
Absolutely, positively sure that you didn't disturb any vacuum lines? This is the mostly cause if it continues to idle high after warm up.
Thanks mate.

Could have possibly, will have a look tonight.

What are the signs i should look out for? as when i last checked they all seemed to be plugged in correctly without leaks.
jemthejem is offline   Reply With Quote Quick reply to this message
 
Old 07-20-2010, 06:35 AM   #4 (permalink)
Newbie
 
jemthejem's Avatar
 
Join Date: May 2010
Posts: 7
Gallery: 0
jemthejem is on a distinguished road
Default

Ok so found the problem, distributor wasn't timed correctly.

Running beautifully atm - when warm, however when car is cold idle gets really low and eventually stalls. (Weather has been really cold in the mornings lately.)

This never use to happen before timing belt change can someone please advise???

Has it got something to do with my cold start??
jemthejem is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:31 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.