electrical question??? - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-13-2010, 04:59 PM   #1 (permalink)
Full Member
 
88suzuki88's Avatar
 
Join Date: Nov 2009
Posts: 131
Gallery: 0
88suzuki88 is on a distinguished road
Default electrical question???

i have an 88 samurai and when its idiling if i rev it... the lights get significantly brighter.. both headlights and instrument lights? i have the stock alternator but it was "beefed up" by a reputable alternator shop and i also have a new optima battery. also my BRAKE light on my gauge cluster is always on??? i have brand new brakes front and rear? and my emergency brake works fine? any ideas why the light is on? the brake fluid should be toped off but i will check that one more time..thanks guys any suggestions are greatly appreciated always...
88suzuki88 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 05-13-2010, 06:11 PM   #2 (permalink)
Member
 
Join Date: Jan 2009
Posts: 71
Gallery: 0
squid is on a distinguished road
Default

first quick check is charging voltage. with a fully charge battery and engine at 2500 rpm, the voltage at the battery should be between 13.5 to 14.8. if voltage falls outside this range the alt is bad. to check the amp out put of alt, the voltage ripple pattern, and battery condition you will need more test equipment. having a repair facility diagnose the charging system will cost as much as the alt or battery. so just pick one and change it. if you are lucky that will fix problem and if not change the other part. 99.9% of the time it is the alt or battery that fails in charging system
SQUID
squid is offline   Reply With Quote Quick reply to this message
Old 05-13-2010, 06:14 PM   #3 (permalink)
Member
 
Join Date: Jan 2009
Posts: 71
Gallery: 0
squid is on a distinguished road
Default

the master cylinder has a fuid level switch, that will turn on light if fluid is low.
squid is offline   Reply With Quote Quick reply to this message
 
Old 05-14-2010, 05:06 AM   #4 (permalink)
Senior
 
Join Date: Jul 2009
Posts: 201
Gallery: 0
whincup is on a distinguished road
Default

mine does exactly the same thing... lights are dim at idle, and once its over about 1500rpm its a fair bit brigher, and highway speeds (~3500rpm @ 100km/h) its perfectly fine. family friend works at a battery shop, and replaced the battery less than a year ago, and at the time said the alternator was putting out about 14.4v at idle (engine warm) and was told it was fine. i think its just that the batteries are small, and the alternator is small...

stock battery size and stock alternator...
whincup is offline   Reply With Quote Quick reply to this message
Old 05-14-2010, 09:59 AM   #5 (permalink)
Senior
 
Join Date: Nov 2009
Location: Mt Juliet, TN
Posts: 293
Gallery: 0
Haptown is on a distinguished road
Default

re: the brake light, there is a switch on the e-brake handle. Make sure that the red/black wire is still connected to the switch and not shorting out. When checking the fluid, make sure that it is at least at the height of the grill inside. On mine, if it gets below it, I will see the brake light come on when making a hard left hand turn.

Does your alternator light come on when you turn the key to the run position but before starting? If no, then you need to replace that light as it is needed for remote sensing by the alternator.

A good headlight mod is to re-wire your headlights and add relays. The stock wiring is just too weak and uses a switched ground which is also subject to problems. Here is a good link to follow
Haptown is offline   Reply With Quote Quick reply to this message
Old 05-17-2010, 06:04 AM   #6 (permalink)
Newbie
 
twiss2k5's Avatar
 
Join Date: Jan 2009
Location: South East UK
Posts: 9
Gallery: 0
twiss2k5 is on a distinguished road
Default

Quote:
Originally Posted by Haptown View Post
Does your alternator light come on when you turn the key to the run position but before starting? If no, then you need to replace that light as it is needed for remote sensing by the alternator.
This wire provides a pre-charge to the alternator coils, as they are not powerful enough (magnetically) to provide the initial charge. It's called an exciter wire. Many alternators should have an exciter lead.
Some alternators (including the one on my 1600 8v sidekick/vitara engine) are "self-exciting" and will start to charge when the revs are high enough.
Without the wire, it will run ok at highway revs, but when doing around town driving, when you're sitting at traffic lights there will be no charge.

It's a bit of a stupid design as it runs through the dash light, so if the dash bulb goes, so does your alternator!
__________________
Twiss2k5

'93 Suzuki Samurai Sport 1600

Last edited by twiss2k5; 05-17-2010 at 06:13 AM.
twiss2k5 is offline   Reply With Quote Quick reply to this message
Old 05-17-2010, 09:53 AM   #7 (permalink)
Veteran
 
Join Date: Jan 2008
Location: San Diego, CA
Posts: 1,230
Gallery: 0
Baratacus is on a distinguished road
Default

what exactly does the alternator light look like? I assume it's in the center idiot light strip, but if it says ALT then I don't think mine lights...
Baratacus is offline   Reply With Quote Quick reply to this message
Old 05-17-2010, 11:46 AM   #8 (permalink)
Senior
 
Join Date: Nov 2009
Location: Mt Juliet, TN
Posts: 293
Gallery: 0
Haptown is on a distinguished road
Default

It is called a Charge Light in the FSM for the non-EFI models. From looking at page 21-2 in the FSM, it is to the left of the Oil Pressure light and to the right of the Brake Warning light. There are 7 lights across the bottom with a big gap between lights 3 & 4 so unsure of the exact placement.

I have a '91 and the light is in the center strip, but have no idea what the icon looks like as my battery is currently disconnected for other repairs. And frankly never paid much attention to it since it never came on while running. The light did work as I replaced all the dash bulbs about two years ago and checked it then.

And thanks Twiss for correcting me on the "exciter" wire. I didn't think remote sensing was correct at the time but I could not think of the correct term. Remote voltage sense is a connection to the alternator where the alternator detects the charging system voltage. On a Samurai this can result in the alternator receiving a lower voltage signal since the the wire is connected to the ignition rather than directly to the battery. This does not cause a big problem with the small stock alternators, but it you upgrade to a high output one, it can result in overcharging of your battery.
Haptown is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:36 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.