Can't maintain idle speed... any guess to what's wrong? - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-14-2010, 12:21 AM   #1 (permalink)
Full Member
 
Join Date: Jan 2010
Location: Boganville, Kweenzlairnd, Ustrailya
Posts: 112
Gallery: 0
che_guitarra is on a distinguished road
Default Can't maintain idle speed... any guess to what's wrong?

The beast is suffering it's first real dilemma in my hands.

Out of the blue (well, kinda), I can't keep a steady idle - i'm having to try pump the throttle to maintain an RPM above 2000 or it's doomed to stall. The car won't even kick over unless I step on the throttle. Take your foot off and you can just see the RPM diving to zero. Even at 2000RPM, in neutral it's impossible to maintain a relatively steady idle until 2000+ RPM. This is kinda scary in the stop/start traffic of suburbia, more so it's a pain the you-know-where - having to reach for the keys at every set of traffic lights. Kinda unsafe on a major level too.


My first suspicion was that a vacuum line (on the stock Hitachi carb) had come loose, or maybe the carb idle speed screw was whacked somehow. But the idle speed screw was correct, and the vacuum lines seemed to be in order... maybe the idle jet got blocked somehow? If not, that's my detective work dead and buried.


The only thing on the carb that gets my attention is a corroded spring on a carb adjustment screw - it's the lowest screw on the carb - side facing the radiatior - it doesn't seem to be holding full tension... infact most of these little tension springs and coils look a little perished.


Other than that i can't see any clues to what might be wrong.


I did replace the throttle cable last week, and that did bump up the idle speed a little to 1300 - 1400 RPM (i assumed the replacement cable was a fraction shorter, but hadn't got around to adjust the idle speed).

I also noticed after a decent highway run when the car was fully up to temperature, the car the idle speed RPM would drop to 1000 - but not in stop/start driving.

This weekend I clocked around 600km (375 mlies) of mainly highway driving - not much, but the car's biggest run yet. I drove back three hours from a fishing mission - and now time to run my weekly errands the car has begun to stall.... badly.

It just seems the hotter the engine the worse this gets - but at the hottest i've seen the temp gauge barely registering a 1/4 on the temp gauge.



Any ideas as to what's going on here?

Last edited by che_guitarra; 02-14-2010 at 02:02 AM.
che_guitarra is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-14-2010, 12:27 AM   #2 (permalink)
Full Member
 
Join Date: Jan 2010
Location: Boganville, Kweenzlairnd, Ustrailya
Posts: 112
Gallery: 0
che_guitarra is on a distinguished road
Default

Infact - are there any Hitachi carburetor diagrams showing the functions of each adjustable screw?
che_guitarra is offline   Reply With Quote Quick reply to this message
Old 02-14-2010, 01:54 AM   #3 (permalink)
Full Member
 
Join Date: Jan 2010
Location: Boganville, Kweenzlairnd, Ustrailya
Posts: 112
Gallery: 0
che_guitarra is on a distinguished road
Default

Now after WD40-ing the carb and refitting all the hosing, replacing new springs, I can get 5 - 10 seconds of normal idle before it stalls.... it wants to work, but now it seems like it's being starved of fuel, than a carb issue

Maybe a fuel line blockage?

Seems the more I persist, the longer I'm getting before it stalls.
che_guitarra is offline   Reply With Quote Quick reply to this message
 
Old 02-14-2010, 03:48 PM   #4 (permalink)
Veteran
 
Join Date: Jan 2008
Location: San Diego, CA
Posts: 1,230
Gallery: 0
Baratacus is on a distinguished road
Default

it's possible that the float is sticking or the carb jets got some junk in them. Run some carb cleaner through it and see if it clears up. It sounds like the carb may just be dirty. I'm pretty sure the FSM has a diagram of the inside of the carb and the function of all it's parts. I know it has a section that tells you how to tune it and adjust it properly.
Baratacus is offline   Reply With Quote Quick reply to this message
Old 02-15-2010, 12:10 AM   #5 (permalink)
Full Member
 
Join Date: Jul 2009
Posts: 117
Gallery: 5
87samurai_dunn is on a distinguished road
Default

i would get a can of starter fluid or brakleen and spray around the carb and intake manifold while its running to check for any vacuum leaks, it might be the carb loose or just a loose vacuum line, but definately sounds like a leak to me
87samurai_dunn is offline   Reply With Quote Quick reply to this message
Old 02-17-2010, 05:23 AM   #6 (permalink)
Full Member
 
Join Date: Jan 2010
Location: Boganville, Kweenzlairnd, Ustrailya
Posts: 112
Gallery: 0
che_guitarra is on a distinguished road
Default

I definitely got something clogging my line. Looking back - I ran the tank real low last weekend until it was almost running on fumes, in the process I probably dragged some gunk from the bottom of the fuel tank into the line and it's got stuck somewhere... I've only owned the car for a couple of months now, so I got no idea what the tank was hiding... maybe I should clean it out? Too late now I guess - the muck is already in the fuel line.


I've put through a bottle of carby cleaner and also a bottle of methylated spirits into the tank - it's worked wonders on my past cars to sort out moisture issues, but not this time.... not in the 400kms i've clocked since the problem began anyway.



How do I check the idle jet? Seems to me if I can run the car at speed but not at idle, it's gotta be a pretty good place to start looking for a problem. Can I access it without taking the whole carby off the manifold?

I'm just asking as this particular carby is far more complicated than the Holleys and Webbers i've tackled in the past - thus more to go wrong.

Last edited by che_guitarra; 02-17-2010 at 05:26 AM.
che_guitarra is offline   Reply With Quote Quick reply to this message
Old 02-17-2010, 10:02 AM   #7 (permalink)
Veteran
 
Join Date: Jan 2008
Location: San Diego, CA
Posts: 1,230
Gallery: 0
Baratacus is on a distinguished road
Default

It's been a while since I had mine appart, but If I remember right there are screws on the bottom that need to come out to disassemble it completely. Check for vacuum leaks first like Samurai_Dunn mentioned. It's really easy to do and inexpensive. If it IS a vacuum leak you'll be kicking yourself for pulling apart the carb for no reason. If it's not, then you can proceed to the carb cleaning. If you crack open your carb you will need a rebuild kit to replace gaskets and seals when you put it back together. The kit should come with a complete detailed set of step by step instructions. I've searched around and can't seem to find any on-line instructions for disassembly and reassembly.

Usually shooting carb cleaner into the openings and vacuum ports is enough to clear mine when it starts running rough. You can fill the float chamber with carb cleaner and let it sit for a while to loosen stuff up. I wouldn't do that unless you're prepared to do a rebuild though because there is the risk of completely clogging the jets if there's heavy sedement that is loosened but not disolved by the solvent.

Last edited by Baratacus; 02-17-2010 at 10:07 AM.
Baratacus is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:58 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.