F10A Issues - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-01-2009, 12:52 AM   #1 (permalink)
 
Join Date: Jun 2008
Posts: 8
Gallery: 0
The Frayne is on a distinguished road
Default F10A Issues

So this has been going on for a lill while..

Ill copy n paste some history -

So not long ago changed over the engine in the ute.
She blew the pistons on the first one and so we have chucked another 1lt in.

Since then, Its been running like a pig on the first run..
You can hear the thing spitting and missing on power down.
Choke helps a little but not that much, It WAS like that for the first 15/20mins each day then would be not too bad..

I took the air intake pipe off the carby and rev'd put the hand over and then cupped the intake, drew a fair amount of fuel and not much grit/dirt.

Changed the fuel filter and this made zero difference..

What is annoying however, is sometimes after a run.. you can let the engine sit for say three hours, will get cold .. then will start first time and not miss a trick.

But since doing the fuel filter, on the first run and almost for an hour (or until i get where im going) she misses and farts and pings..
Almost sounds like a rock hitting the lid of the bonnet sometimes.. sharp ping..

Also, She is now loosing all power when she misses, power down clutch fully out and ZERO power like you have put your foot back on the clutch.
Enough to jolt your body forward..
I give it heaps of revs and she will go again, then next time (stop and go) say at lights, same thing.. power down.. move then BAM complete loss of drive and movement.. Again clutch in, rev the bollocks of it..
and she goes..

Its extremely dangerous as I almost got cleaned up today when I pulled out of a junction with plenty of time, but lost all power and stalled right in the middle of the road..
Shit my pants and almost flooded the engine getting back going..

Thing is i'm conscious of revving the bollocks off it and stressing the engine ..

Carby?

also add that the is an audible sound of spitting, like a sprinkler chocking/limiting out water.. if that makes any sense.. The power through gears is extremely laboured ..

==

Since then I have replaced, Fuel and Oil Filters. Put in some premium fuel.
Changed all spark plugs, Dizzy Cap, Points and Leads..
New Oil Change.

This has sorted out the complete dead spots, however it is missing and farting and doing my head in..
==

After getting pissed off with it, I gave her a few days off and the following clip is the result.

She drives very erratically, pings and misfires in 4th mostly, but in every gear if you're not ranting it..


Cheers guys!

Dave.
The Frayne is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 07-02-2009, 01:47 PM   #2 (permalink)
Member
 
Pilsner Pig's Avatar
 
Join Date: Nov 2008
Location: Quesnel, BC
Posts: 94
Gallery: 3
Pilsner Pig is on a distinguished road
Default

It sounds like an electrical arc! are all the plug wires in good shape? Coil wire?
Pilsner Pig is offline   Reply With Quote Quick reply to this message
Old 07-04-2009, 04:34 AM   #3 (permalink)
 
Join Date: Jun 2008
Posts: 8
Gallery: 0
The Frayne is on a distinguished road
Default

Just to let ya know..

The timing was completely retarded..

Dizzy mounted way to the left, centered and adjusted and its running sweet..

Thank F*** for that!
The Frayne is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:44 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.