samurai fuse problems Please help - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-14-2009, 09:51 PM   #1 (permalink)
 
Join Date: Feb 2009
Posts: 2
Gallery: 0
lawnmowerracing2 is on a distinguished road
Default samurai fuse problems Please help

hi i have a 1990 samurai with EFI, i have had it for 2 months and it is my daily driver and has been running excelent until yesterday. it blew the 15 amp F I fuse which runs a bunch of things. i put a new one in and it worked for 20 minutes or then blew out again. everything seems to work, radio, lights, starter, but the fuel pump shuts off. so i tried another fuse and blows as soon as the key is turned on. i have tried to check for bare wires and shorts in the wire harness but found nothing. now i am at a stand still and don't have the money to bring it to the dealer . any advice you have would be nice to hear, thanks Jason
lawnmowerracing2 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-15-2009, 09:31 AM   #2 (permalink)
 
Join Date: Feb 2009
Posts: 88
Gallery: 1
Harleyindahouse is on a distinguished road
Default

1st thought; fuel pump failure (shorted) or you maybe looking at a computer failure.
You can or should be able to hear the fuel pump whirl momentarily when you trun the key on till the fuel pressure is up.

Uncommonly the fuel pump relay can fail but unlikely! It is east to isolate but any problems with fuel pump you are likely going to need a complete fuel pickup assembly with fuel pump because it probably severly rusted.

You could probably do the easiest test if you pull the fuel pump relay and bypass the relay at the four pin plug socket lower left dash... relay should be attached to computer case bracket.
Harleyindahouse is offline   Reply With Quote Quick reply to this message
Old 02-15-2009, 09:35 AM   #3 (permalink)
 
Join Date: Feb 2009
Posts: 88
Gallery: 1
Harleyindahouse is on a distinguished road
Default

btw: if you end up needing a computer I probably have 99% certain!

$120.00 tested working
Harleyindahouse is offline   Reply With Quote Quick reply to this message
 
Old 02-16-2009, 12:02 AM   #4 (permalink)
Member
 
Join Date: Jan 2009
Posts: 71
Gallery: 0
squid is on a distinguished road
Default blown fuses

this is where the wire diagram would come in handy. one fuse may power several items.
if fuse blows as soon as ignition is turned on , you can unplug things intill it stops and what ever item is unpluged is your suspect.

I use a "short finder" avalable in most part stores. it is a circuit breaker which is put in place of fuse and a small gauge which is placed near the wiring. the needle swings back and forth when it is near the wire that has the short, then the gauge is move down the wire and the needle will stop when short is past .
squid is offline   Reply With Quote Quick reply to this message
Old 02-16-2009, 02:28 AM   #5 (permalink)
 
Join Date: Feb 2009
Posts: 88
Gallery: 1
Harleyindahouse is on a distinguished road
Default

I just looked at diagram; "lawnmower" identifies his problem at fuse # F1(circuit is constant live) connected input (b/r) to main relay. From main relay "load" circuits are (b/w) to stop lamp switch, (bl)main relay to ECM, and (bl/b) main relay to emmision control devices; solenoid purgue valve, EGR sv valve , TCC relay but these (3) all trace back circuits to ECM.

I have a short detector but becuase of the confined spece it is not practical and usually only used for long line circuits.

Find the main relay first; you could in fact only have a problem with a shorted relay but it it the relay near the ECM "4 wires" I would unlug the main relay first and use a jumper wire in place on the connector from black/red to any of the other three terminals one at a time to black/white, then black/red to blue, then black/red to blue/black.... look for the black/red to blue jumper to blow the fuse.... That is the ECM!....

This will isolate which circuit is affecting fuse the most..... but also lower your test fuse value to say 5 amp max for these tests.
Harleyindahouse is offline   Reply With Quote Quick reply to this message
Old 02-17-2009, 05:50 PM   #6 (permalink)
 
Join Date: Feb 2009
Posts: 2
Gallery: 0
lawnmowerracing2 is on a distinguished road
Default

thanks for all the information. i unpluged every connector in the wire harness in the sami and turned the key and it didn't blow the fuse, then slowly plugged in the rest one at a time with no blown fuse. then i pluged in the fuel pump and blew it instantly. so i thought it was drawing too many amps so i hooked it up to a spare battery with homemade jumper wires and a 15 amp fuse. i let it run fr about 30 minutes and it didn't blow the fuse. so for now i just ran some 14 gage wire from the pump to the key switch with i 15 amp fuse and it is working great so far. i know it probably isn't the correct way to do it but it works for now. Please let me know what you think about what i did and if it will hurt somehting.
lawnmowerracing2 is offline   Reply With Quote Quick reply to this message
Old 02-17-2009, 08:34 PM   #7 (permalink)
 
Join Date: Feb 2009
Posts: 88
Gallery: 1
Harleyindahouse is on a distinguished road
Default

Quote:
Originally Posted by lawnmowerracing2 View Post
thanks for all the information. i unpluged every connector in the wire harness in the sami and turned the key and it didn't blow the fuse, then slowly plugged in the rest one at a time with no blown fuse. then i pluged in the fuel pump and blew it instantly. so i thought it was drawing too many amps so i hooked it up to a spare battery with homemade jumper wires and a 15 amp fuse. i let it run fr about 30 minutes and it didn't blow the fuse. so for now i just ran some 14 gage wire from the pump to the key switch with i 15 amp fuse and it is working great so far. i know it probably isn't the correct way to do it but it works for now. Please let me know what you think about what i did and if it will hurt somehting.
Not good becuase you will likely fry something else; computer will fail shortly most definately!!!!!

Fuel pump relay is mounted on the computer and there is a test for the fuel pump but unfortunately that is a normal occurance. You must remember that you are bypassing all control processing for emissions but if the pump is seizing which is common it will take out the computer.
Harleyindahouse is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 09:05 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.