No High Beams - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-02-2019, 09:42 AM   #1 (permalink)
Member
 
Join Date: Feb 2013
Posts: 71
Gallery: 0
inthedirt is on a distinguished road
Default No High Beams

Just picked up a 1987 Samurai, although not my first. Came with some horrendous LED lights that have been swapped out for some halogens. Was hoping to increase the amount of visible light for the driver while not blinding oncoming cars. That problem is now resolved, but I still have one lingering problem: no high beams.

I thought the problem may have been in the adapters that were used with the LEDs, but not so much. Low beams work as expected, the high beams will flash when the stalk is pulled, but I get nothing when the stalk is pushed to lock the high beams on. Just blackout. My multimeter is on the fritz and will need to order a new one, but can someone verify if the stalk switches the ground or the power, and which wires at the headlight plugs should be getting power when the switch is on and off. Thanks.

I'm guessing that I'm going to need a new switch assembly as the lights and wipers are slow to activate when rotated. Figure the contacts are dirty, and the switch is cheap enough, I may just replace it. Thinking of also building a relay system so the lights get their power directly from the battery rather than the factory system.
__________________
Current Ride:
1987 Samurai, soft top

Previous Rides:
1985 SJ410, tin top
1986 Samurai, soft top
1996 Geo Tracker 16v, 4dr, 4wd, 5spd
1996 Sidekick Sport, 1.8L, 4dr, 4wd, 5spd
inthedirt is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
High beams on with low beams J63812F General Forenza & Reno Forum 3 04-02-2018 01:09 PM
High beams and low beams GVs_2 2G (1999-2005) Vitara & Grand Vitara 10 12-16-2017 10:06 AM
No DRL and low beams .. but Hi beams work jeegro Suzuki Sidekick, Escudo, Vitara, Geo, X-90 & Tracker Forum (1989-1998) 27 06-24-2010 12:48 PM
High Beams Work, but NO LOW BEAMS!! Please help!! Schmeg Suzuki Forenza & Reno Forum 3 11-14-2009 08:05 AM

Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:09 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.