1998 sidekick 1.6 cold start issues - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-03-2018, 07:18 AM   #1 (permalink)
Newbie
 
Join Date: Feb 2018
Posts: 15
Gallery: 0
PDXrhett is on a distinguished road
Default 1998 sidekick 1.6 cold start issues

I blew a water pump last week so I changed all the belts and timing belt, tensioned correctly across the board. A couple days later I try to start my engine in about 42F weather and it floods. Unflood works 15% of the time (guessing the % here). Once it starts, I can shut it down and start it back up easy. Now, on that first start it sounds like it is misfiring or something else for about 4 seconds then it clears up and runs perfect. What could it be. I don't want to go shotgunning and throwing parts at it. Any help is appreciated
PDXrhett is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-03-2018, 07:19 AM   #2 (permalink)
Newbie
 
Join Date: Feb 2018
Posts: 15
Gallery: 0
PDXrhett is on a distinguished road
Default

Water pump is new also.
PDXrhett is offline   Reply With Quote Quick reply to this message
Old 02-06-2018, 08:59 AM   #3 (permalink)
Newbie
 
Join Date: May 2017
Posts: 17
Gallery: 0
jingusflob is on a distinguished road
Default

You double check timing after changing the belt? Could have jumped a tooth. Had a similar problem. Ended up being belt was off.
jingusflob is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:06 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.