Choke/Cold Idle Problems - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-13-2017, 09:21 PM   #1 (permalink)
Newbie
 
Join Date: Sep 2016
Posts: 6
Gallery: 0
Allanrps is on a distinguished road
Default Choke/Cold Idle Problems

I have a 1986 Samurai with stock Hitachi carb.

My car runs well when warm, but I am having problems with the cold idle. For the last 6 months I have been driving it with the choke held open and the cold idle set screw screwed all the way in. The car would start and idle at around 800 rpm cold and warm.

Today I took the carb off and made sure everything in the choke linkage was moving as it should, and it was. The choke plate closes under spring power and opens from the vacuum actuator, throttle, and coolant temp. I put it back and started the car.

It idles pretty rough at like 700 rpm, but when I take off the the air horn while running, thereby disconnecting the vacuum hose from the intake connecting the two, the idle immediately raises to 1300-1400, going strong right where I want it to be. When I started the car without the air horn, it started at the 700 rpm the same way until I played with the choke plate by hand and it settled at the same high idle. I couldn't tell a visible difference and do not know what is going on. When the engine is hot everything works as expected and I get 23 mph with a big rack on top.

Anybody have any insight? Thanks!
Allan
Allanrps is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:06 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.