F10A engine problems - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-23-2008, 04:50 AM   #1 (permalink)
Newbie
 
Join Date: Jan 2008
Posts: 3
Gallery: 0
createtech is on a distinguished road
Default F10A engine problems

I have a Suzuki Carry fitted with a F10A engine. The truck has been running perfectly until I left it for 2 weeks. I started the motor and it leaked/spewed out all its oil and water. The valve cover ventiallation tube was like a hose with oil and water mixture. The sump was full with water. There was no milky stuff just a mixture of oil and water.
Its as though a bung has fallen out and leaked the water into the sump.
What can cause this? Any help would be great.

Phil
createtech is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 04-23-2008, 08:01 AM   #2 (permalink)
Newbie
 
Jakkals's Avatar
 
Join Date: Apr 2008
Location: Pretoria, South Africa
Posts: 21
Gallery: 0
Jakkals is on a distinguished road
Default

I had exactly the same! This was due to a blown head gasket. The water then leaks through to the sump, and with the heat the water evaporates and then condenses into the hose. The reason why everything is spitting out, is because some pressure from the combustion chamber escapes into the sump, and this blows out everything - All thats needed is to take the head off, skim it if necc, do a pressure test and refit with a new head gasket! Hope this helps!
Jakkals is offline   Reply With Quote Quick reply to this message
Old 07-12-2017, 10:21 PM   #3 (permalink)
Newbie
 
Join Date: Jul 2017
Posts: 1
Gallery: 0
suzukicarrynz is on a distinguished road
Default non interference or interfernce

hi i am wondering if the valves could be bent on my suzuki carry 1.0L after the timing belt snapped. it has a F10A engine 1988. Also would anyone happen to know if it has 8 valves?
suzukicarrynz is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:21 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.