Toyota carb..help..baffled - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-10-2016, 09:35 PM   #1 (permalink)
Newbie
 
Join Date: Nov 2016
Posts: 2
Gallery: 0
jet_airman is on a distinguished road
Cool Toyota carb..help..baffled

Ok. So I got a 1988 Suzuki samurai about 2 months ago. it has the Toyota 3K carb conversion just like the a ACK frequently asked questions guide. I took it out on the road several times and it will not go above 40 mph after tinkering with it and tuning it; I realized the secondary jet was not opening up. I was probably only running on one barrel. I decided to go ahead and get another carb and installed it the secondary opens fine and I thought everything would be good. I took it for a road test and it still will not go above 40 miles an hour in either fourth or fifth gear with the pedal floored.....
Any body have a clue as to why this is happening or how to remedie this.
My next guess is to go through or see if I can adjust the throttle cable.
Thanks
airman
jet_airman is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-26-2017, 12:33 AM   #2 (permalink)
Newbie
 
Join Date: Jan 2017
Posts: 21
Gallery: 0
Walt_M is on a distinguished road
Default

Quote:
Originally Posted by jet_airman View Post
Ok. So I got a 1988 Suzuki samurai about 2 months ago. it has the Toyota 3K carb conversion just like the a ACK frequently asked questions guide. I took it out on the road several times and it will not go above 40 mph after tinkering with it and tuning it; I realized the secondary jet was not opening up. I was probably only running on one barrel. I decided to go ahead and get another carb and installed it the secondary opens fine and I thought everything would be good. I took it for a road test and it still will not go above 40 miles an hour in either fourth or fifth gear with the pedal floored.....
Any body have a clue as to why this is happening or how to remedie this.
My next guess is to go through or see if I can adjust the throttle cable.
Thanks
airman
Your cable may be too long or the linkage is loose fitting and it will not fully open because there isnt enough pull or fit is off.
Walt_M is offline   Reply With Quote Quick reply to this message
Old 02-26-2017, 07:46 AM   #3 (permalink)
Moderator
 
Join Date: Mar 2009
Location: Georgetown, Guyana
Posts: 11,948
Gallery: 0
fordem will become famous soon enough
Default

You've told us very little about the vehicle, I suspect because you very little about the vehicle, and that makes it hard to diagnose what's happening.

Some more details might prove helpful - what size tires are you running?

Many of these vehicles have been lifted and larger rubber fitted - if this is done without gearing changes to compensate, the performance may be significantly affected.

What condition is the engine in - for that matter what engine do you have in it?

If the engine is the original 1.3 litre G13, it's probably tired - wet & dry compression tests will give you an idea of the engine condition. Engine swaps using the 1.6 G16 from a Sidekick or Tracker are quite common, and whilst they do provide more power, your Samurai will never be a speed demon, especially with larger rubber.
__________________
98 - 1.8 Mitsubishi Pajero iO
98 - 2.0 Suzuki Grand Vitara - SQ420
05 - 2.0 Suzuki Grand Vitara - JB420
15 - 2.4 Kia Sportage
fordem is online now   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:42 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.