Carb Problems! - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-23-2016, 02:44 AM   #1 (permalink)
Newbie
 
Join Date: Sep 2016
Posts: 6
Gallery: 0
Allanrps is on a distinguished road
Exclamation Carb Problems!

Hi all,

I just took the carb off to go through everything, as I have to go through emissions testings and know everything isn't 100%. After popping the top off, I sprayed out all the passages, set the float, set the choke, and made sure everything was clean. However, now that it's on the car again, when I try to start it the car revs out of control.

The throttle linkage side valve is closed, I'm not sure about the the other plate, but it looks to me like they're on the same shaft? I bottle tested the float bowl level, and it doesn't fill up. It looks like all the gas is leaking out of the accelerator pump somehow, dripping from the carb body below it. The base of the carb is wet with gas. I took the choke and the wot/closed throttle switch linkages apart, and while I'm pretty sure I got everything together right, I don't have any good diagrams to verify.

Does anybody know whats up? I'm pretty desperate as this is my only vehicle and it needs to get me to work tomorrow, or it will probably be towed....

Thanks
Allanrps is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-23-2016, 05:56 AM   #2 (permalink)
Veteran
 
Darrell.'s Avatar
 
Join Date: Jun 2014
Location: UK
Posts: 4,932
Gallery: 0
Darrell. is on a distinguished road
Default

What country are you in (Aisin or Hitachi carb). I can't offer advice on this, but should be able to find some diagrams/info on either.
__________________
2005 Grand Vitara MT 1600se.
Darrell. is offline   Reply With Quote Quick reply to this message
Old 10-23-2016, 06:39 PM   #3 (permalink)
Newbie
 
Join Date: Sep 2016
Posts: 6
Gallery: 0
Allanrps is on a distinguished road
Default

It's a Hitachi carb. I figure out my initial problems. I had bent the bracket holding the vacuum actuator of the secondary butterfly valve, which caused it to stay open. The boot on the accelerator pump was also ripped which, along with the tilt of the car, allowed the gas to flow out without filling the bowl properly.

I now have a new problem though.... When the car idles it has a very lowd sqeak/buzz. It sounds like its coming from the carb or fuel pump. As I get on the throttle it dies out, and by like 1/8th throttle it is completely gone. When traveling at speed if I release the throttle it returns. The car now idles poorly also, and I can't consistently set the idle. Anybody heard this before? It's got to be a common problem
Allanrps is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:03 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.