Everything quit working. - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-19-2007, 02:46 AM   #1 (permalink)
Newbie
 
Join Date: Oct 2007
Posts: 4
Gallery: 0
ohso is on a distinguished road
Unhappy Everything quit working.

I have an 87 Samurai that quit while it was running. I lost everything.
No lights. No reaction when I turn the key in the ignition. Nothing run by electricity works. The battery is up and the ground is good. There is continuity from the positive terminal to any metal part on the vehicle. Is there a main fuse somewhere in the system?
ohso is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-19-2007, 06:24 AM   #2 (permalink)
Newbie
 
Join Date: Oct 2007
Location: Lancaster County, PA
Posts: 7
Gallery: 0
Ronzuki is on a distinguished road
Default

There's a fusible link right off the positive battery terminal. It's not your typical fuse, instead it's an actual piece of wire down the positive cable. If it's open, deteriorated, or corroded....could be your problem.
I've never actually seen one "blown" but I'd imagine if it is, you've got other issues.

Ron
Ronzuki is offline   Reply With Quote Quick reply to this message
Old 10-19-2007, 09:54 PM   #3 (permalink)
Newbie
 
Join Date: Oct 2007
Posts: 4
Gallery: 0
ohso is on a distinguished road
Default

Quote:
Originally Posted by Ronzuki
There's a fusible link right off the positive battery terminal. It's not your typical fuse, instead it's an actual piece of wire down the positive cable. If it's open, deteriorated, or corroded....could be your problem.
I've never actually seen one "blown" but I'd imagine if it is, you've got other issues.

Ron
Thank you Ronzuki. I will check that first thing in the morning.
Ohso
ohso is offline   Reply With Quote Quick reply to this message
 
Old 10-20-2007, 08:05 PM   #4 (permalink)
Newbie
 
Join Date: Oct 2007
Location: Lancaster County, PA
Posts: 7
Gallery: 0
Ronzuki is on a distinguished road
Default

no problem....any luck with your problem?
Ronzuki is offline   Reply With Quote Quick reply to this message
Old 10-20-2007, 09:10 PM   #5 (permalink)
Newbie
 
Join Date: Oct 2007
Posts: 4
Gallery: 0
ohso is on a distinguished road
Talking It is working now.

Ronzuki,
It was a simple fix. One corroded wire coming off the battery with the starter wire.
Thanks again.
ohso is offline   Reply With Quote Quick reply to this message
Old 10-24-2007, 08:09 PM   #6 (permalink)
Newbie
 
Join Date: Oct 2007
Location: Lancaster County, PA
Posts: 7
Gallery: 0
Ronzuki is on a distinguished road
Default

glad to help
Ronzuki is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:07 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.