1988 sammy question on high idling please - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-31-2015, 04:28 PM   #1 (permalink)
Newbie
 
Join Date: Dec 2009
Posts: 19
Gallery: 0
roblee is on a distinguished road
Default 1988 sammy question on high idling please

Hey my friends its been awhile but I have a problem if my exp. guys can help please. I changed my valve cover, sparkplugs, cleaned out carb, rotor, etc. now before I had no idling problems at all, Now it revs over 3100rpm cold and hot. can anyone help? thanks a lot.
roblee is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-31-2015, 04:43 PM   #2 (permalink)
Veteran
 
Darrell.'s Avatar
 
Join Date: Jun 2014
Location: UK
Posts: 4,944
Gallery: 0
Darrell. is on a distinguished road
Default

Have you dislodged any of the vacuum pipes off the carb whilst cleaning.
That's what first come to mind.
__________________
2005 Grand Vitara MT 1600se.
Darrell. is offline   Reply With Quote Quick reply to this message
Old 08-31-2015, 09:24 PM   #3 (permalink)
Newbie
 
Join Date: Dec 2009
Posts: 19
Gallery: 0
roblee is on a distinguished road
Default

Yes sir all vacuum lines are connected. Can anyone else make a suggestion
roblee is offline   Reply With Quote Quick reply to this message
 
Old 09-02-2015, 08:21 AM   #4 (permalink)
Senior
 
Azelgin's Avatar
 
Join Date: Oct 2010
Location: S. E. Arizona
Posts: 264
Gallery: 0
Azelgin is on a distinguished road
Default

I don't believe in coincidences. There is a 95% chance your issues are from something you touched. It ran fine, you worked on it, now it doesn't. Keep looking for a vacuum leak, or, carburetor related issue.
Azelgin is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 07:49 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.