Engine revs up and down after warmup, 90 samurai - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-27-2007, 02:47 PM   #1 (permalink)
Newbie
 
Join Date: Jan 2007
Posts: 2
Gallery: 0
RebuildIt is on a distinguished road
Default Engine revs up and down after warmup, 90 samurai

I would appreciate some insight on this problem.
Whenever i start it up, it runs smooth until the engine reaches
its operating temperature, then the idle starts whining up and down.
It seams to stop after i hit the gas pedal, but then it comes back a minute or so later..
Does anyone have any idea on how to fix this..?
Thanks
RebuildIt is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-28-2007, 01:45 AM   #2 (permalink)
Newbie
 
Join Date: Jan 2007
Posts: 18
Gallery: 0
Pommy is on a distinguished road
Default Up and Down...

Hi,

What happens if you floor it for a second (out of gear!) ?

Does it struggle, pause, or rev up normally?

If normally, I would suggest the cause may be the idle solenoid.

(Get one from a wreckers if you can due to OEM being expensive)

If not, I would clean the carb in one of two ways -

1. Buy a spray from your local automotive shop CARB-I-CLEAN or something like that - it just sprays in with the engine running.

2. Take the carb off and do it the harder, but proper way (still using the spray)

Cheers,

Pommy.
Pommy is offline   Reply With Quote Quick reply to this message
Old 01-29-2007, 08:30 PM   #3 (permalink)
Newbie
 
Join Date: Jan 2007
Posts: 2
Gallery: 0
RebuildIt is on a distinguished road
Default Revs

If i floor the gas, the revups seem to be consistant (no hesitation).
Its only when it idles.
But It statred doing that after I have swaped in a the exhaust from a swift, (same motor) and i put in a new O2 sensor. To me that should make no difference at all to the way the car idles.
I will try to spray some carb cleaner into ot and see if that will take care of the problem, if not i will try to change the idle solenid..
Thanks Pommy.
RebuildIt is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:49 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.