Bad Fuel??? - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-23-2015, 02:18 AM   #1 (permalink)
Newbie
 
Join Date: May 2015
Posts: 1
Gallery: 0
NLowrey is on a distinguished road
Default Bad Fuel???

Hi all,

I was hoping to get some help with an issue for my Suzuki Jimny 08 JB43V, I have recently replace the fuel filter, and it seems to still have issues with (what I think) is fuel. I have just taken the tank off again, checked all the fuel lines, tank, fuel quality, but am convinced there is still an issue but perhaps not fuel! Where do I start to eliminate causes??? The problem it causes is kind of like hiccups, or heart murmers, it seems to skip a beat!!! it got a lot worse before I changed the filter, almost loss of power, and no grunt anymore!! Can anyone please help me assess the issue, and hopefully finally get to the bottom of the issue!!

Regards,
Nicky
NLowrey is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-09-2015, 03:48 PM   #2 (permalink)
Newbie
 
Join Date: Jun 2015
Posts: 1
Gallery: 0
bongobenny is on a distinguished road
Default Injectors

Hi there, I have been having fuel problems with my little suzuki also. Have you tried changing your spark plugs? I am about to drop my fuel tank and put a new filter and pump. I also would like to get my injectors done. think i might have to pull them out and bring them to AFI for a bubble jet clean cause suzuki want $310 for each injector new! I have the G13BB engine.
bongobenny is offline   Reply With Quote Quick reply to this message
Old 06-10-2015, 09:58 AM   #3 (permalink)
Guest
 
Join Date: Jun 2008
Location: The Kingdom of England
Posts: 5,299
Gallery: 5
Rhinoman is on a distinguished road
Default

If the problem is cutting out when hot then it is usually a cam or crank sensor problem.
Rhinoman is offline   Reply With Quote Quick reply to this message
 
Old 08-12-2015, 09:11 PM   #4 (permalink)
Newbie
 
Join Date: Feb 2015
Posts: 4
Gallery: 0
zookpasion is on a distinguished road
Exclamation shudder!!

i have the same problem when my suzuki sierra 1.3l warms up. its a 1995 and 3rd, 4th and 5th all chudder and loose grunt until i hit about 90km p/h it sits at 3 thousand rpm comfortably. not sure if you have the same problem but my odometer jumps during these gears from 2 thou - 8 thou continuously??

ive been told to clean fuel lines, do a carby tune, reset timing etc.. $$$

ive replaced the fuel filter, air filter, done all new gaskits everwhere and reset tappets.

my air intake butterfly flap before the actual air box doesn't work and im missing the occasional hose here and there over the whole engine, the coal box? isn't attached to anything and my hot air hose is gone??

really confused as i do not think my engine has cam sensors?? ind im not in any position to spend $$$

pls if anyone can give me the cheapest way to fix these problems it would be greatly appreciated
zookpasion is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:18 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.