1992 samurai no spark need some guidance - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-21-2015, 01:22 PM   #1 (permalink)
Newbie
 
Join Date: Jan 2015
Posts: 1
Gallery: 0
ford_sammy is on a distinguished road
Default 1992 samurai no spark need some guidance

my sammy died one day and i checked for spark, i wasnt getting any spark from the coil. coil fuse was good, i couldnt get the box coil and a friend had a spar old canister style coil that i wired. it got spark once and blew the fuse. replaced the fuse and had no spark at all now.

I came across an online manual to diagnose no spark issues and found ohm readings for the coil to test it. the ignition coil tested good. i could not find any ratings for the ICM , but i wasnt getting any resistance from it at all. and I wasnt getting any voltages off the ecu. except for a couple pins which had maybe 0.3 ish volts.

is there a way to test the icm or should i just replace both the ecu and icm first
ford_sammy is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 05-21-2015, 08:29 PM   #2 (permalink)
Newbie
 
Join Date: May 2015
Location: Arkansas
Posts: 8
Gallery: 0
Brown29 is on a distinguished road
Default

Quote:
Originally Posted by ford_sammy View Post
my sammy died one day and i checked for spark, i wasnt getting any spark from the coil. coil fuse was good, i couldnt get the box coil and a friend had a spar old canister style coil that i wired. it got spark once and blew the fuse. replaced the fuse and had no spark at all now.

I came across an online manual to diagnose no spark issues and found ohm readings for the coil to test it. the ignition coil tested good. i could not find any ratings for the ICM , but i wasnt getting any resistance from it at all. and I wasnt getting any voltages off the ecu. except for a couple pins which had maybe 0.3 ish volts.

is there a way to test the icm or should i just replace both the ecu and icm first
I would suggest checking your main relay first. It is one of the 2 relays on brackets at the top of the ECM. The relay with the pink/black striped wires is the fuel pump relay and the other is the main relay. If these relays are not attached to the ECM they should be dangling from the harness close by. If either of these are bad, the motor will not start. If it is not a problem with the relay it may be your ECM. If you do not have the 1990 - 1994 TBI supplement to the Factory Service Manual you can download it here: http://suzukiinfo.com/sierra/ It will explain about retrieving diagnostic codes in section 4A and the codes are at 4A-34.
Brown29 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 03:26 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.