1991 running rich - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-06-2015, 10:11 PM   #1 (permalink)
Newbie
 
Join Date: Apr 2015
Posts: 1
Gallery: 0
Mondo204 is on a distinguished road
Default 1991 running rich

1991 efi was running spotty, had to feather gas to keep running.
Brought to mech and the code read tps sensor , so we replaced it. Same thing continued . Replaced oxygen sensor , same thing. Then he shows me that it runs with mapp sensor unplugged (electrical). Suggests bad mapp sensor so I replace that too. Same thing, so been running without mapp for awhile but it runs rich for awhile then engine light comes in when driven for an hourish time.
One time after a bit if driving it without mapp then it wouldn't run even w it disconnected , so I experimented and took off one vacuum line off of air box and it ran again, but not quite right.
Is it the ecu?? Can't return any electrical parts and a little ticked.
It is a fun vehicle. Any ideas .
Replaced exhaust last year, new plugs and new pcv valve and plugs!
Mondo204 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 05-03-2015, 09:23 PM   #2 (permalink)
Member
 
Puddlejumper's Avatar
 
Join Date: Jan 2011
Location: Cypress,Tx
Posts: 33
Gallery: 0
Puddlejumper is on a distinguished road
Default

Replace the fuel pressure regulator located on the front of the throttle body.
__________________
91 EFI Daily driver, weekend warrior and deer hauler
Puddlejumper is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 04:26 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.