1986 model not starting - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-03-2015, 07:04 PM   #1 (permalink)
Newbie
 
Join Date: Mar 2015
Posts: 6
Gallery: 0
genesis.himself is on a distinguished road
Default 1986 model not starting

Hey fellas. Got a sammi with a 1600 8 valve engine. Took it completely apart for some bodywork and now i'm reassembling. The previous owner did alot of crazy wiring that took me a while to sort out. So far i'm getting power from the ignition to the starter, it cranks but doesn't start. Checked the coil and there is no power coming out of it to the distributor and when im testing the coil i get power on both the negative and positive sides which an old mechanic tells me is normal? this where im stumped. I've been reading posts for the past hour and none seem to help me. Any input what so ever will be greatly appreciated. Thanks.
genesis.himself is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-04-2015, 03:23 PM   #2 (permalink)
Guest
 
Join Date: Jun 2008
Location: The Kingdom of England
Posts: 5,299
Gallery: 5
Rhinoman is on a distinguished road
Default

Have you got the ground wire from the distributor to the firewall?
Rhinoman is offline   Reply With Quote Quick reply to this message
Old 04-06-2015, 09:51 PM   #3 (permalink)
Newbie
 
Join Date: Mar 2015
Posts: 6
Gallery: 0
genesis.himself is on a distinguished road
Default

All grounds were good the problem was that i mixed up the distributor plug with the coil plug.
genesis.himself is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:04 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.