Loss of power and Squeaking - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-30-2014, 07:32 PM   #1 (permalink)
Newbie
 
Join Date: May 2014
Posts: 1
Gallery: 0
flores.671 is on a distinguished road
Thumbs down Loss of power and Squeaking

This morning when i was driving my samurai to work i downshifted just before i reached an inclined road and my engine started to lose power. i would feed it more gas but nothing would happen and sometimes it would get worse so i would let off the gas (kinda felt like the carb was flooding the cylinders with too much gas). later down the road it went away and as i was pulling up to the parking lot it started doing it again. i got to work fine and parked but as i was getting all my stuff out and the car was idling i began to hear this metallic squeaking as if there was a bad bearing. i went to work and when i came back to my car and started it up again it made the same noise but even louder. turned off the car and pulled it into a garage bay and check for any obvious damage. sufficient engine oil and no contamination like water, coolant, or metal shavings. pulled the valve cover off and didn't see any obvious damage or water. there was oil present so i know there is sufficient oil pressure. pulled the belts off and checked the pulleys and they were all fine. can't really pinpoint the noise at this point because its too loud and i don't want to run the engine that long with that horrible noise. PLEASE HELP!!!

Confused Broke-anic
flores.671 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:00 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.