87 Sami with weber fuel problem? - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-03-2014, 11:13 PM   #1 (permalink)
Newbie
 
Jasonw1990's Avatar
 
Join Date: May 2014
Location: Reading PA
Posts: 22
Gallery: 0
Jasonw1990 is on a distinguished road
Default 87 Sami with weber fuel problem?

hello, new to the site to hopefully find out the little quirks and fixes for my 87 samurai. So far i dumped roughly 2k$ in it with parts still needed to be put in. But first thing's first the fuel problem....

As im driving 1rst and 2nd gear will rev up to 5-6k nicely hit 3rd and up it wont pass 3k or it will bog HARD sumtimes shutting off, will have to clutch kick to get it safely off the road. This has just started maybe 2-3 weeks ago, my brake light switch came loose leaving my lights on 1 night and the battery died. Let it sit maybe a week seeing as i work 3rd and im drained when i get home, i jumped it on the weekend and drove it around to let it charge but got up to speed in 3rd and bogged down, up shifted 4th did good til 3-3.5k then had to shift again same with 5th but with the rev's its limiting me to only 45-50 before it go kaput. Starts up fine except after it bogs and shuts offon its own, some reason the bowl keeps emptying and not re-filling at higher revs. The weber has that nice little rectangle port which i use to see fuel level which i can see the bowl IS empty as well as when its topped off.

Now for possible fixes i have tried; new pump (getting fuel to the carb no problem, hooked the line to a glass bottle to check volume/flow [plus if there was any water in it from sitting]) all good there, i am on my 3rd filter thinking they have been getting clogged but only 1 had chunks in it still no fix after putting in a new 1. The carb float, just re-checked it tonight and its fine, paperwork that came with the weber says a totally different setting than everywhere else ive found it online (tried both settings and still no go). Jets, thinking maybe it needed re-jetting i went thru each jet size back and fourth and nothing seemed to help aside from a bit more upmh. Sprayed ether around the gaskets looking for leaks, nothing. Was gunna try blowing out the fuel lines and cleaning the tank thoroughly but havent had much energy to do so yet seeing as i just topped off my tank so i could drive the dang thing -.- dont really wanna drain it to drop the tank. This thing has me stumped on how its just recently started doing this after the battery died i've checked other things i.e spark which is excellent (new everything aside from the dizzy itself and cap), plugs have that nice color to em maybe a bit more brown than normal but in other words fine....if anything else im missing on what to check be free to share with me, open to suggestions, i will be goin thru the lines and tank possibly a new 1 when i get the chance just dont know when that will be.

Mods so far; Weber 32/36, L.R.O.R. 272 cam (wast of money IMO), and a thrush muffler. everything engine wise is pretty much stock/stock replacement.
Jasonw1990 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 06-25-2014, 10:28 AM   #2 (permalink)
Newbie
 
Jasonw1990's Avatar
 
Join Date: May 2014
Location: Reading PA
Posts: 22
Gallery: 0
Jasonw1990 is on a distinguished road
Default

solved, my "NEW" mech. fuel pump took a crap after about 200 miles so went and got an electrics cheapy which is working wonderful
Jasonw1990 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:55 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.