Warranty Problems - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 08-23-2005, 03:35 AM   #1 (permalink)
 
Join Date: Aug 2005
Posts: 1
Gallery: 0
cemm2001
Arrow

Very unhappy with my garage. They have changed my brake discs and pads three times now to eliminate vibration when it reaches 50mph, all wheels have been changed, balanced and tracking done too. They are now saying it may be the wheels themselves that are causing the problems. The wheels are standard alloys and should be covered under warranty. The vehicle itself has not been off road at all, even if it had the wheels should be able to handle it!! Where do I legally stand because I am at the end of my patience now. Other problems included oil leaks, cam belt, steering, suspension, the list goes on! Someone please advise!!!
cemm2001 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-23-2005, 07:46 PM   #2 (permalink)
 
Join Date: Oct 2004
Posts: 290
Gallery: 0
Ming is an unknown quantity at this point
Default

I would go to another Suzuki dealer. Make some overtures about how you will switch and buy from them next time. Be really friendly about it - don't look like you are at your wits end and about to pop. They might surprise you with their service.
Ming is offline   Reply With Quote Quick reply to this message
Old 08-23-2005, 10:16 PM   #3 (permalink)
Member
 
tom_riddle's Avatar
 
Join Date: Sep 2004
Location: BF Homes, Paranaque Manila Philippines
Posts: 87
Gallery: 0
tom_riddle
Default

i used to have the same problems with my jimny. the suzuki dealer here changed the tie rod ends. that is after a long investigation suspecting me hitting a big rock which is not true.

try the suggestion of ming. bring it to another suzuki dealer.
tom_riddle is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:59 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.