1987 Samurai, engine quits when I turn on my lights - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-05-2014, 06:34 PM   #1 (permalink)
Newbie
 
Join Date: Mar 2010
Location: Colonial Heights, Virginia
Posts: 10
Gallery: 0
UncleWade is on a distinguished road
Default 1987 Samurai, engine quits when I turn on my lights

1987 Samurai, been running fine but now it just died when I went to drive to the store, it was dark, turned the lights on and it shut off and it wont start up. New battery but I don't know the condition of the alternator. any ideas?
UncleWade is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 02-06-2014, 07:15 AM   #2 (permalink)
Senior
 
Azelgin's Avatar
 
Join Date: Oct 2010
Location: S. E. Arizona
Posts: 264
Gallery: 0
Azelgin is on a distinguished road
Default

Need more information.
Does it crank? (starter spins engine when key is turned)
Any other electrical systems work? - lights, turn signals, gauges, radio, etc. . .
Check all fuses at firewall fuse block?
Check battery cables?
Check battery ground?
Check battery to body ground?
Check engine to body ground?
Check fuseable link at battery to main wiring harness?
Azelgin is offline   Reply With Quote Quick reply to this message
Old 02-06-2014, 09:00 AM   #3 (permalink)
Newbie
 
Join Date: Mar 2010
Location: Colonial Heights, Virginia
Posts: 10
Gallery: 0
UncleWade is on a distinguished road
Default

thanks for replying! I did get it started again last night and as soon as I disconnect the battery cable it shuts off again. so I took the alternator off last and will get it checked today. I hope that's all it is!
UncleWade is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:59 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.