suzuki samurai starts great but dies after 1 second - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-18-2014, 03:42 PM   #1 (permalink)
Newbie
 
Join Date: Jan 2014
Posts: 1
Gallery: 0
east is on a distinguished road
Default suzuki samurai starts great but dies after 1 second

I changed the battery on my samurai and now it runs great but dies after about a second unless you pat the gas pedal every time it stalls. Any ideas. Thanks in adv. It is fuel injected
east is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 01-19-2014, 04:53 AM   #2 (permalink)
Newbie
 
Join Date: Apr 2013
Location: Donnybrook, West Australia
Posts: 2
Gallery: 0
Joe SJ51T is on a distinguished road
Default

Hi East,
I had a similar problem with my 87 Sierra with the automatic choke. The workaround I used is to simply dis-engage the choke mechanism. Been almost 18 months trouble free, only overhead is a longer warm up in winter.
Joe SJ51T is offline   Reply With Quote Quick reply to this message
Old 01-19-2014, 04:57 PM   #3 (permalink)
Newbie
 
Join Date: Jan 2014
Location: Cincinnati
Posts: 1
Gallery: 0
Zuked is on a distinguished road
Default

i had this issue, for me it ended up being a clogged fuel filter.
Zuked is offline   Reply With Quote Quick reply to this message
 
Old 01-20-2014, 07:21 PM   #4 (permalink)
Newbie
 
Join Date: Apr 2009
Location: Canada
Posts: 5
Gallery: 0
dwagener is on a distinguished road
Default

Could be a spark advance vacuum hose that is detached or leaking?
dwagener is offline   Reply With Quote Quick reply to this message
Old 01-22-2014, 11:59 AM   #5 (permalink)
Full Member
 
Join Date: Nov 2013
Location: Willamette Valley, Oregon
Posts: 111
Gallery: 0
samuraijack is on a distinguished road
Garage
Default

I would check the grounds also, just to be safe lol
and dwagner is right about the vaccum hose.
do you have a water choke?
samuraijack is online now   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Jimny, Sierra & Samurai Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 01:00 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.