Misfire code, oil in throttle, resonator, and tubes from valve cover - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Forenza & Reno Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-23-2013, 09:23 PM   #1 (permalink)
Newbie
 
Join Date: Mar 2013
Posts: 2
Gallery: 0
djwitham82 is on a distinguished road
Default Misfire code, oil in throttle, resonator, and tubes from valve cover

hi, I have an 05 forenza 130k, I keep having misfires, rough idle, and I recently found a hole in the big air intake hose between the resonator and the air filter box so I removed it to tape it up until the new one comes in the mail, also removed the resonator and saw that there was oil in the resonator, opened up the throttle and looked in, theres a little bit of oil in the bottom, and the hose from the resonator to the valve cover was very cruddy, so I removed the other two hoses stemming from the valve cover and there is oil in both of them, I assume the hose from the front of the valve cover is the drainage hose to the oil pan, but the two on back one small one to the throttle body and and the larger one to the resonator, I don't know what their purpose is and if either sould have oil in them, I think one of them is the pcv hose?

Anyway I taped up the hole and replaced the resonator (have to get a new one because most of the tabs are broken where it fits onto the throttle body) drove about 30 or so miles and it was great, and then the stuttering and terrible idle started again, I think maybe its pcv valve letting oil into resonator and throttle but I am not sure any ideas/suggestions?

I don't really have a good mechanic I left it for 9 hours at shop and he came up with nothing didn't even notice the*huge* hole in the intake, so I would appreciate any suggestions!!thanks!
djwitham82 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 03-27-2013, 10:08 PM   #2 (permalink)
Veteran
 
Join Date: Feb 2007
Location: ny
Posts: 3,098
Gallery: 11
7-even is on a distinguished road
Default

hi welcome to the forum!! ok lets start with the hoses and the oil. with this motor you tend to get a lot of whats called blow by. simple explanation, when pressure builds up in the motor its released into the intake and reintroduced back into the motor by way of the throttle body. the blow by carries with it oil which gets into the intake track and tends to gum up the system. ok so, the hoses, the front one drains back to the oil pan. looking at the motor on the back left side one goes to the intake one to the throttle body. the one to the intake is for the blow by, the other caries coolant to the throttle body to keep the throttle body from freezing in intense cold. oil in the coolant line is not a good sign. ill have to double check which is the coolant line tomorrow im not positive which one it is by memory. so, oil in the intake, line to the intake from valve cover and in the throttle body is normal. this all leads us to what your idle problem probably is ok inside the throttle body is whats called the idle air control valve. basically it controls the idle of the car. what tends to happen is that the blow by gets on the valve and it stops working correctly. you can either get a new one OR give it a clean and see what happens. heres a link to another thread where cleaning the iac is talked about.
https://www.suzuki-forums.com/suzuki-...-question.html
if you have any questions about this just ask.you could also clean out the intake and give the throttle body a little wipe out. this leads us to your other problem of back fires. not sure about this one i think you should get the new intake on the car and deal with the iac valve. the car should idle like new when this is taken care of. with some luck maybe itll deal with the back fire also. if not we can move on to figuring that out. let me know if you have any other questions and let us know what happens
7-even is offline   Reply With Quote Quick reply to this message
Old 03-28-2013, 01:04 PM   #3 (permalink)
Newbie
 
Join Date: Mar 2013
Posts: 2
Gallery: 0
djwitham82 is on a distinguished road
Default

THanks for all the advice! I have the car in shop right now and they think it is
An injector issue, so he's going to investigate that further, another question I have is that the hose from the valve cover to the throttle I think you said coolant hose got destroyed a couple years ago and I replaced it with a thicker hose because the original was so flimsy would that cause problems? Anyway I will definetely look into the aic on my next day off thanks again for all the help
djwitham82 is offline   Reply With Quote Quick reply to this message
 
Old 03-29-2013, 01:17 PM   #4 (permalink)
Veteran
 
Join Date: Feb 2007
Location: ny
Posts: 3,098
Gallery: 11
7-even is on a distinguished road
Default

hi no a thicker hose wont cause problems. i almost positive the idle issues is the iac. ive had this problem as well as a few others on the forum. i doubt its anything to do with the injector but see what they find.
7-even is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Forenza & Reno Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 08:25 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.