'07 Forenza Trans...what did I do wrong? - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Forenza & Reno Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-02-2012, 08:59 PM   #1 (permalink)
Newbie
 
Join Date: Feb 2011
Location: California
Posts: 10
Gallery: 0
Chobie 01 is on a distinguished road
Default '07 Forenza Trans...what did I do wrong?

I was re-installing the engine in my '07 Forenza...everything lined up, there was a little struggle getting it all the way together, so I started some bolts on the top, worked around the front slowly installing the bolts. Just as I was tightening the last few bolts...I heard a loud pop and fluid was flowing out of the trans on the drivers side end, and there's a huge crack....what did I do...and can it be fixed? Thanks Chobie
Chobie 01 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 11-03-2012, 11:32 AM   #2 (permalink)
Newbie
 
Join Date: Feb 2011
Location: California
Posts: 10
Gallery: 0
Chobie 01 is on a distinguished road
Default

ok, so I took the engine out again....it apears the the cover on the trans is where the crack is...I'm thinking that when i removed the engine the first time, the torque converter moved out a bit..is there something behind it that could have maybe shifted?
I don't know anything about transmissions....so if anyone could give me some insight it would be greatly appreciated. Thanks, Chobie (Scott)
Chobie 01 is offline   Reply With Quote Quick reply to this message
Old 11-11-2012, 09:59 PM   #3 (permalink)
Full Member
 
Join Date: Sep 2012
Location: WV
Posts: 143
Gallery: 0
19bonestock88 is on a distinguished road
Default

you may be able to get the trans case welded...
__________________
[COLOR="Silver"]2005 Suzuki Forenza S[/COLOR]
5 speed, full Pioneer audio system upgrade

[COLOR="Black"]2002 Saturn L200[/COLOR]
2.2 L61, auto, wife's car...
Pioneer stereo installed from previous owner, 251k miles, stock

[COLOR="Red"]1988 Ford ranger RCSB[/COLOR]
2.0/5 speed, 2wd
roller cam conversion, misc "free" mods, more to come...
19bonestock88 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Forenza & Reno Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 10:19 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.