Help? - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Forenza & Reno Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-03-2009, 03:22 PM   #1 (permalink)
 
Join Date: May 2009
Posts: 1
Gallery: 0
mark5743 is on a distinguished road
Default Help?

I have an 04 Suzuki forenza and my engine light came on. i took it to auto zone and have them check the code that is reading on the engine light. The code reads P0441( EVAP Emissions System Incorrect Purge Flow). I had the gas cap changed and had the dealer change the filler neck. But the light came on again. I dont know what else to do.
mark5743 is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 05-04-2009, 05:46 PM   #2 (permalink)
Member
 
Join Date: Aug 2006
Posts: 82
Gallery: 0
francster is on a distinguished road
Default

Sounds more like either your charcoal canister is clogged or one of your lines is crimped or loose\leaking causing the fumes to run backwards. Maybe one of the Pro's here can give you more insight.
francster is offline   Reply With Quote Quick reply to this message
Old 06-25-2009, 10:26 AM   #3 (permalink)
Member
 
Join Date: Apr 2009
Posts: 89
Gallery: 0
onlyhuman is on a distinguished road
Default

mine did the same thing.. when the light came on, i took it to advance to get the code. The part that gives that error is a dealer part. So I took it to my mechanic right after.. around 6 pm. He was closing up. Told me to come back first thing in the morning and he'll check it out.

I had a hunch. I disconnected battery to reset the error when I got home cause advance auto didn't do it. It never came back on.

First response from my mechanic was to check the fuel cap.

The light came on.. on the day when it was cold in the morning, and VERY hot in the afternoon.. late spring.

See, my opinion is that.. because 04 forenza is new.. it would have a lot of threshold issues in the settings that the on board computer handles. Because of the huge temperature day in one day.. caused unbalanced pressures on the valves.. and triggered an error.

Once reset, it never came back on.

Try that.
onlyhuman is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Forenza & Reno Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 06:10 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.