No head light on my 2005 Forenza - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Forenza & Reno Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-16-2007, 08:51 PM   #1 (permalink)
 
Join Date: Mar 2006
Posts: 12
Gallery: 0
mykewl
Default No head light on my 2005 Forenza

Hey everybody: I have a problem. I have no Low beams whatsoever. At first I thought that the bulbs blew out. I went out and boughts some new bulbs but before installing them I checked for 12v at the sockets. No B+. I then plugged the old bulbs in to the High beam socket and they checked out good.

Figuring that the problem has to be in the fuse box I got my multimeter out and checked the wiring up to the fuse box under the hood. The wiring checked out OK up to the two fuses (LT lo, RT lo beam). There at that point I realized I have no B+ (12v) to the lobeams (fuses are good). If I connect B+ to the fuse I get the lights to work. Checked all the fuses and swapped the relays, still no low beams.

I figured that the problem would have to be in the DRL module. I called the dealer to get some insight about the probelm and the location of the DRL module, but you know how the dealer is, I got nothing. Anyway, I get the gist from the posts that the DRL module can be disconnected and the light still work. So I guess my problem is not in the DRL module.

My question to all: Does anyone have a wiring diagram for this car or might know where to look?

Thanks.
mykewl is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-16-2007, 10:04 PM   #2 (permalink)
Full Member
 
Join Date: Nov 2005
Posts: 124
Gallery: 0
SuzukiTech
Default

here is your problem

https://www.suzuki-forums.com/general...beam-fuse.html
SuzukiTech is offline   Reply With Quote Quick reply to this message
Old 09-17-2007, 11:02 PM   #3 (permalink)
 
Join Date: Mar 2006
Posts: 12
Gallery: 0
mykewl
Default Thank you kind sir!!!

Thank you. You saved me a great headache
....
mykewl is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Forenza & Reno Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 12:32 AM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.