Turn Signal and Hazard and Middle Horn Not Working Suzuki Forenza 2004 - Suzuki Forums: Suzuki Forum Site
Suzuki Forum Suzuki Forums

» Auto Insurance
» Featured Product
Wheel & Tire Center

Go Back   Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Forenza & Reno Forum
Register Home Forum Active Topics Photo Gallery Garage Search Today's Posts Mark Forums Read Auto EscrowAuto LoansInsurance Advertise

Suzuki-Forums.com is the premier Suzuki All Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-24-2015, 08:19 PM   #1 (permalink)
Newbie
 
Join Date: Oct 2015
Posts: 1
Gallery: 0
zille is on a distinguished road
Default Turn Signal and Hazard and Middle Horn Not Working Suzuki Forenza 2004

I have a Suzuki Forenza 2004. I had over heating issue which is fixed but the turn signal and hazard does not work. When turn the light switch all light works. I changed the turn signal switch, hazard switch, both black relay one with three and another with more than three pin. Still no luck. Sometime when start the car after one day it works for 20 second and stops. I dont hear the click sound but I get the light flashing and stop after 20 second. Can anyone advice what is the problem?
zille is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 10-25-2015, 05:24 AM   #2 (permalink)
Veteran
 
Darrell.'s Avatar
 
Join Date: Jun 2014
Location: UK
Posts: 4,933
Gallery: 0
Darrell. is on a distinguished road
Default

As you have replaced the major components on this circuit I can only suggest using a multimeter to check continuity/voltage. Something like a bad earth on the relay (blinker unit) will cause issues.
This diagram is from the Daewoo Lacetti workshop manual but I believe the Forenza is the same.

__________________
2005 Grand Vitara MT 1600se.
Darrell. is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

  Suzuki Forums: Suzuki Forum Site > Suzuki Models > Suzuki Forenza & Reno Forum

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Suzuki Forums: Suzuki Forum Site forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:
Insurance
Please select your insurance company (Optional)

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.3

All times are GMT -5. The time now is 05:40 PM.



Powered by vBulletin® Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.